Announcement

Collapse
No announcement yet.

351 W Oil pump

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 351 W Oil pump

    anybody ever have to mess with there oil pump? My 76 351 (reverse rotation) starts and runs, but has no oil pressure. I removed the sending unit and nothing comes out of the block (engine running)

    I pulled the dist. today, and I don't see any receiving gear inside of the block for an oil pump.

    I bought the boat at auction, and have only gotten it to run this week.

    Anybody know if the marine oil pump is different than a ford truck oil pump? Anything else I should check when I pull off the oil pan?

    thanks...

  • #2
    Is there a gear on the cam under the distributor? How about the condition of the gear on the distributor shaft?

    Comment


    • #3
      the dist looks good, cam gear is good. I pulled the dist, and it doesn't look like there is anything for the bottom of the dist to fit into.

      Comment


      • #4
        So, there's no hex hole on the bottom of the distributor gear? Is there a hex rod inside the motor when you look into the hole in the intake manifold?

        Comment


        • #5
          Possibly someone removed the distributor and the hex drive cam out with it and fell off or was not reinstalled.....

          Comment


          • #6
            hex cam rod? Huh?

            I bought the boat without the distributor installed. Is there supposed to be a rod under the dist? It does look like there is a hex hole wayyyyyy at the bottom of the dist hole... Would this be a common part? Can I install it without pulling the pan? What keeps it from moving while I install the dist?

            Anybody know where I could find a dist rod?

            Comment


            • #7
              aha haaaaa Eurika

              http://www.coasthigh.com/oil_systems...mit2=Oil+Pumps

              "oil pump drive shaft" eh.

              Huh, AMC engines don't have those...

              Thanks guys, I'll post if it works, but I'm sure it will. I just hope I didn't ruin my engine running it without it...


              ==============

              I had to buy a new pump shaft (found the new one the day after...) runs much better now... The hardest part was getting everything to line up again to re-install the distributor
              Last edited by scramblerkid; 08-14-2004, 11:13 PM.

              Comment

              Working...
              X