Announcement

Collapse
No announcement yet.

MCX Engine issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MCX Engine issues

    Hey ya'll
    While wakeboarding (04 xstar) the other day we had the low oil pressure alarm come on twice (gauge read 0). We turned it off immediately, let it rest for a couple minutes and fired her back up with normal oil pressure (25-40 PSI). We checked the oil level and it looked fine, boat was not running hot either. Other than the oil pump, could this be anything else?

    Another issue we had was a little lifter tick in the engine. One of my other friends has an 04 tige with the GM vortec 5700 (from what I understand the MCX and this engine are very similar) and had the same lifter tick. Ran some valve cleaner through it and havenít heard the tick since. Wanted to know if anyone has had similar problems with the MCX.

  • #2
    Could be a bad filter. I've seen this happen where the filter will collapse. I would say it's the sending unit, easy fix, but the valve tick makes worry a little
    Lots of power is good, more is better, too much is just right.

    '91 prostar 190

    Comment


    • #3
      I would pull off the valve covers and ck your rocker arms to see if one has maybe come loose. On the oil press problem the first thing I would do is check the pil pressure sending unit and the oil press alarm switch.

      Comment


      • #4
        I would look into the oil filler hole and see if you have oil running from the higher valves (front of the motor, not the boat) to the lower ones. If you see no oil at any RPM, use a mechanical oil pressure gauge.

        Comment

        Working...
        X