Announcement

Collapse
No announcement yet.

Fuel Sending Unit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fuel Sending Unit

    I have a 1998 Prostar 190 and the fuel gauge may have to be replaced. The boat is in storage now so I can't match the sender up. Are there different part numbers (different gauges) or are they all the same? I would like to get one ready so I don't have to go shopping in the spring and waste time.

  • #2
    They are all not the same. I would call the guys over at Midwest MasterCraft in Crystal, MN and they should be able to hook you up. Good idea to plan ahead. If you are handy, you may just need to recalibrate your empty and full settings on your sender. This depends on the symptoms of your gauge. Either way the guys at Midwest MC can walk you through the diagnosis.

    http://www.waterskis.com/

    Comment


    • #3
      If it's the sending unit, you can fix it yourself pretty easily. There's a thread in the FAQ section about it. My 96 read full all the time, I followed the instructions, glued the magnets back in place and was done in about an hour and a half, including unbolting the tank and sliding it forward to get at it.

      Comment


      • #4
        and you can buy direct here...

        http://www.isspro.com/
        sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

        Comment


        • #5
          I personally have not experienced the problem. I just bought the boat and will have to wait until next season to see exactly what the gauge says. The PO told me that he would fill it up and the gauge comes to half full. That makes me think possibly he used the 10% Ethanol and there may be some corrosion on the sender. My previous experience is with a sending unit in a Correctcraft that has a type of rheostat that can rust. I'm assuming that this is not the case with the units Matercraft uses. I will give the guys at Midwest Mastercraft a call.
          Thanks for the replies.

          Comment


          • #6
            Originally posted by Snipe View Post
            I personally have not experienced the problem. I just bought the boat and will have to wait until next season to see exactly what the gauge says. The PO told me that he would fill it up and the gauge comes to half full. That makes me think possibly he used the 10% Ethanol and there may be some corrosion on the sender. My previous experience is with a sending unit in a Correctcraft that has a type of rheostat that can rust. I'm assuming that this is not the case with the units Matercraft uses. I will give the guys at Midwest Mastercraft a call.
            Thanks for the replies.
            Not usually corrosion on these senders- the magnets release from the float or the float foam can swell. Get access to the sender and turn the key on, then connect from the pink wire to the black. If the needle deflects to Full, your gauge is fine.

            In this case, you can file a little off of the slots in the float that were binding and make sure it slides to the top without hanging up. I used a file that's just a little thicker than the board in the sender. If it lost one, or both magnets, you'll need to remove the sender, remove the round plate on the bottom and remove the float/magnet(s) that fell off. Position the magnet(s) in the float and turn the key ON, then slide the float from bottom to the top, making sure it reads correctly. You may need to reverse one of the magnets. Use Super Glue gel to keep it in place.

            Comment


            • #7
              Do you happen to know the height of the tank in my 98?
              I have an access hole in the transom, I may be able to get that thing out without having to remove the tank.

              Comment


              • #8
                Originally posted by Snipe View Post
                Do you happen to know the height of the tank in my 98?
                I have an access hole in the transom, I may be able to get that thing out without having to remove the tank.
                No, but I repaired quite a few senders that worked for at least a few years after they were affected by the MTBE/ethanol in the gas.

                Contact MC and give them your hull ID numbers- they'll be able to tell you the original part number for the sender and it can be cross-referenced. If you change to the new style, use the one that was sent as a generic replacement. The only difference in using that and the ones specific to each model is the length and it was the best way for dealers to avoid having to wait while the one they needed had to be shipped (paraphrasing Murphy's Law, "The part's you have in stock aren't the parts you'll need in an emergency"). A small pipe cutter (the kink used for copper plumbing) is cheap and an easy way to cut it to length.

                If you search the thread archive, you may find the part number.

                Comment


                • #9
                  You can also call http://www.skidim.com/ I believe they have done a lot of that leg work and will send you the right part.
                  sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

                  Comment


                  • #10
                    I replaced the sending unit in my 98 with a unit from WEMA USA. I have been very happy with its performance so far (2 seasons ago). I was able to replace it with the sun deck off of the back of the boat (access holes beneath it) and the tank in. I believe I measured my tank and it was 8" deep. The website says to take 1" off of the length for plastic tank flex, so I ordered a 7". They are an inline type unit that seems to be very reliable. It would be best if you could measure your tank depth to be sure though.

                    Comment


                    • #11
                      I think my measurement for depth might have been a little off though, as I can peg the gauge on E and it still runs ... but thats better than running out at a quarter tank. I did use tape measure down the sending unit hole to measure.

                      Comment


                      • #12
                        Also forgot to mention that you can test if its the sending unit or gauge by grounding the signal wire from the sending unit to gauge. Unhook the signal wire and it should read empty, ground the signal wire and it should read full. If thats backwards someone chime in.

                        Comment


                        • #13
                          This has been a lot of help. Unfortunately I still have to wait for spring weather to do these suggestions. I just wanted to get on top of things so I have a direction to follow. As I said in earlier posts, "It will be a long winter for me."
                          This is a really helpful site, and the folks that have responded are awesome. Thank you all!!

                          Comment


                          • #14
                            Originally posted by ricford View Post
                            If it's the sending unit, you can fix it yourself pretty easily. There's a thread in the FAQ section about it. My 96 read full all the time, I followed the instructions, glued the magnets back in place and was done in about an hour and a half, including unbolting the tank and sliding it forward to get at it.
                            I can't seem to locate this thread.

                            Comment


                            • #15
                              Try this plenty of info just google MC sending unit magnet

                              http://www.mastercraft.com/teamtalk/...ad.php?t=38453
                              99 MariStar 230 Sport LTR 330

                              Comment

                              Working...
                              X