Announcement

Collapse
No announcement yet.

X7 Predator Engine Problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • X7 Predator Engine Problems

    I was out this weekend enjoying the first nice weekend in Oregon on my X7 with my 2 year old son as my first mate, and had to get towed back to the launch, BUMMER. Anyhow, we were on the water for several hours just cruising the river and stopping every so often to relax. Toward the end of the day, after a stop, the boat wouldn't start. I cranked just fine and had enough fuel. Any thoughts on why it might not be working? Could it be the fuel filter or fuel pump? I just thought it was weird that the boat was working fine and then just wouldn't start back up.

  • #2
    my money is on the fuel pump - giving up it's ghost...
    sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

    Comment


    • #3
      Inspect the fuel filter before you spring for a new fuel pump. I had this happen to me because I got some bad fuel at a marina. Flushed the tank, changed the filter and all was good. Now I run with Seafoam all the time - everytime.
      Screws fall out all the time, the world is an imperfect place.

      Comment


      • #4
        Not to be a smart a$$ but are you sure your kill switch lanyard was seated/installed properly - maybe it got knocked loose?

        Comment


        • #5
          I forgot to mention that I did check the kill switch first thing.

          Comment


          • #6
            Same thing happened to me last year with my Predator after having it out once. Took it to the MC dealer and they replaced the starter. I was suprised it went so fast since it went with no warning at all. At the end of the season I had the fuel filter replaced as a precautionary measure.

            Comment


            • #7
              Originally posted by Nelsonjeff79 View Post
              Same thing happened to me last year with my Predator after having it out once. Took it to the MC dealer and they replaced the starter. I was suprised it went so fast since it went with no warning at all. At the end of the season I had the fuel filter replaced as a precautionary measure.
              He posted that it cranked fine, just wouldn't start.

              Comment


              • #8
                Originally posted by ORSkier View Post
                I was out this weekend enjoying the first nice weekend in Oregon on my X7 with my 2 year old son as my first mate, and had to get towed back to the launch, BUMMER. Anyhow, we were on the water for several hours just cruising the river and stopping every so often to relax. Toward the end of the day, after a stop, the boat wouldn't start. I cranked just fine and had enough fuel. Any thoughts on why it might not be working? Could it be the fuel filter or fuel pump? I just thought it was weird that the boat was working fine and then just wouldn't start back up.
                Time to bare your soul and tell us what you know about engines and troubleshooting. Did you look inside of the flame arrester, to see if any fuel was being delivered to the throttle body? Did you check for spark? What about popped breakers?

                Comment


                • #9
                  I had this happen to me twice, once was the fuel pump, the other was the fuel pump relay...

                  Comment


                  • #10
                    On my predator engine. Even with the kill switch off. Motor still cranks. Just doesn't fire up


                    Sent from my iPad using Tapatalk

                    Comment


                    • #11
                      Originally posted by carlsonwa View Post
                      On my predator engine. Even with the kill switch off. Motor still cranks. Just doesn't fire up


                      Sent from my iPad using Tapatalk
                      The kill switch kills spark, not the starter. The neutral safety switch does that.

                      Comment


                      • #12
                        My experience with dead kill switch is it cranks and sounds like its started but dies when you release the key.

                        Fuel pumps buzz @the key to on then stop.

                        Comment

                        Working...
                        X