Announcement

Collapse
No announcement yet.

MCX 350 De-Winterizing help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MCX 350 De-Winterizing help

    I bought a 2004 X-10 with 350hp MCX engine last Fall and had it winterized by my local dealer. Yesterday, I pulled it out of its winter resting place and am ready to get out on the water within the next month or so.

    I called my dealer to see what needed to be done to "de-winterize" the boat and my salesman described it as a "reconnection of various things, then running the engine to make sure it doesn't overheat." He stated he could do it for $90-100 or I could do it because "it's pretty simple."

    He left a bag with three parts attached to the steering wheel (see photo.)

    I am fairly handy and expect that I could figure this out with some problem-solving, however, I'm hoping someone on the list will see these three parts and be able to direct me in where to look, what to do, etc.

    The hose clamp is pretty straight-forward, I expect. I'll just look for a loose hose and then reattach it to a logical location. Likewise for the brass plug - - - it's location (I'm hoping) should be obvious. I'm curious about the third part however and want to make sure I get things reconnected correctly.

    So far, I've just glanced quickly at the engine. I saw a hose with standard "garden hose" types of connectors underneath the engine on the starboard side. I'm assuming I simply reconnect that hose. Then, as I said above, I thought I would find a place for those three parts.

    I'm hoping someone could give me a quick step-by-step on this, as it would save me a few minutes of head-scratching. Thanks in advance.
    Attached Files
    2004 X-10

    186,000 miles per second - - - not just a good idea, it's the law.

  • #2
    The round odd-shaped plug is a knock sensor/block drain plug. It goes on the port side of the engine, about the middle of the engine (front to back aspect) and on the lower part of the engine above the oil pan. You will also see a one wire connector that need to be plugged into the top of the sensor. The other plug goes on the starboard engine side, same location. Not sure exactly where the hose clamp came from.

    Comment


    • #3
      Originally posted by Meeker View Post
      The round odd-shaped plug is a knock sensor/block drain plug. It goes on the port side of the engine, about the middle of the engine (front to back aspect) and on the lower part of the engine above the oil pan. You will also see a one wire connector that need to be plugged into the top of the sensor. The other plug goes on the starboard engine side, same location. Not sure exactly where the hose clamp came from.
      ^Exactly what he said^


      Sent from my iPhone 4S using Tapatalk
      WaterSkis.com***WakeBoards.com

      Midwest MasterCraft***Midwest Water Sports

      Facebook WaterSkis.com

      Comment


      • #4
        Thanks for the help. That will make it much quicker for me.

        Also, with the garden hose connections on the starboard side - - - I'm assuming that I should reconnect those? Does anyone have experience with that?

        I am assuming the garden hose connection is to help drain water from the cooling system, but realize I may be wrong about that.

        Thanks, again.
        2004 X-10

        186,000 miles per second - - - not just a good idea, it's the law.

        Comment


        • #5
          Hope you didn't pay much for the winterization if that's all he did.

          You'll want to see if he did any of the suggested maintenance when he did this work which I doubt. With a new to you boat the first thing I would change would be the impeller. Going though the engine checking hose clamps, belts and obstructions in the transmission cooler would be the next items on my list. Finish that off with greasing the fittings on the steering cable, shift cable and transmission linkage should get you in pretty good shape.

          Comment


          • #6
            The 2 bolts are your engine block drain plugs, the one with the large black piece is for the knock sensor. Trying to remember your engine/year, I think it goes on the port side, there should be a wire and plug that connects to the black piece. The other plug goes on the opposite side of the block.

            The clamp is most likely off of the J hose, should be on the Starboard side, rear of the engine.

            Yes, be sure to re-connect the garden hose, these are the exhaust drains. If not, you can sink the boat pretty darn quick. You should also replace the raw water impeller if it was not done last fall.

            Comment


            • #7
              Excellent. This is exactly what I was hoping for. Thanks for the help.

              @bturner2 - - - the dealer did quite a bit more with the winterization last Fall. I have very solid confidence in my local MC dealer, which is a relief. I just wanted to do things myself if possible. These replies make it a lot easier.

              Will also check if the impeller was changed out last Fall. If not, I'll add that to the list.
              2004 X-10

              186,000 miles per second - - - not just a good idea, it's the law.

              Comment


              • #8
                Originally posted by musicmd View Post
                Excellent. This is exactly what I was hoping for. Thanks for the help.

                @bturner2 - - - the dealer did quite a bit more with the winterization last Fall. I have very solid confidence in my local MC dealer, which is a relief. I just wanted to do things myself if possible. These replies make it a lot easier.

                Will also check if the impeller was changed out last Fall. If not, I'll add that to the list.
                The guys at Redline are a good group, very respectable dealership.


                Sent from my iPad using Tapatalk
                WaterSkis.com***WakeBoards.com

                Midwest MasterCraft***Midwest Water Sports

                Facebook WaterSkis.com

                Comment


                • #9
                  Agreed. They have been great so far. I think we're lucky to have a great dealer in the area.
                  2004 X-10

                  186,000 miles per second - - - not just a good idea, it's the law.

                  Comment


                  • #10
                    Caution! When you install the knock sensor, be careful not over tighten it. I hear if you apply too much pressure it will break.

                    Comment


                    • #11
                      Thanks for the tip. The knock sensor seemed like it would be breakable. I'll tighten as much as seems prudent then check for leaks.
                      2004 X-10

                      186,000 miles per second - - - not just a good idea, it's the law.

                      Comment


                      • #12
                        How do you guys run the engine after these steps to ensure everything is correct? Out of water to be specific?

                        Comment


                        • #13
                          See the link below!

                          http://www.mastercraft.com/teamtalk/...ad.php?t=44490


                          Sent from my iPhone 4S using Tapatalk
                          WaterSkis.com***WakeBoards.com

                          Midwest MasterCraft***Midwest Water Sports

                          Facebook WaterSkis.com

                          Comment


                          • #14
                            I assume the large hose clamp is for your water intake hose that attaches to the hull intake on the starboard side. Mine has 2 clamps, I think yours should also. You wouldn't want that hose to pop off, your boat would sink fast.

                            I'm surprised they didn't remove your batteries for winter. I always put mine in the house where it's warm, hit them with the trickle charger once in a while.
                            I was njskier on here.

                            Comment


                            • #15
                              Did you buy this boat from the dealer, or privately? If it was from the dealer, get the invoice for all of the work they did because, being in the Midwest, it's possible that they didn't do everything needed for winterization and they should be held responsible in the event that you find problems.

                              Look at the lowest hose on your water circulation pump (it's like the one on a car)- if the hose isn't attached at the pump outlet, I would guess that the hose clamp is for that.

                              Comment

                              Working...
                              X