Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #11  
Old 12-05-2019, 11:54 PM
Thrall's Avatar
Thrall Thrall is online now
MC Maniac
 
Join Date: Jul 2004
Boat: '06 X2 MCX
Location: Black Diamond, WA
Posts: 4,826
If you need a hand checking it out, idk where in the pnw you are, but if your close by to me and need some help let me know
__________________
'06 X2 MCX

"I understand why some people may not want to do this the way I have recommended but I can't understand the death grip some people have on a toilet plunger with a hose fitting." -JimN
Reply With Quote
  #12  
Old 12-06-2019, 01:28 AM
cbryan70's Avatar
cbryan70 cbryan70 is offline
MC Maniac
 
Join Date: Jul 2006
Boat: 1993 Prostar 205
Location: midwest
Posts: 4,679
I would like to share that I have launched my boat without the plug in, launched my boat without the water intake attached, tried to launch my boat with the rear tie downs on, and tried to drive away while the anchor was still down.......all of this is my 15 years of owning a boat(a lot happens from year 1-5 and age 19-24). **** happens I hope you didn’t smoke anything to expensive.
__________________
Quote:
Originally Posted by Hoosier Bob
She always misses me and when I turn her on it is hard to turn her off! She is MC and she completes me! She is the first ride that wants it as much as I do!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:10 AM.


2018