Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-26-2020, 11:06 PM
Torchwork Torchwork is offline
TT Newbie
 
Join Date: Jul 2020
Boat: Mastercraft x45 2005 8.1
Location: Southeast
Posts: 10
New to me '05 x45

Just got an x45 with an lq9 and it runs awesome except I go full throttle and it feels like the trans slips unless I back off to around 3/4 throttle. Engine revs but no acceleration and running smooth as well. Does this throughout the day, warm or cold. Has 1285 prop and is super clean. Trans fluid looks and smells good, same with motor oil. Has 400 hrs on the gauge.

Has a little bit of a high pitch wine around 3k+ rpms but I think I read somewhere that can be normal. It's not that loud, but I figured I would mention it. I'm about to change the spark plugs, tig weld the manifold casting which start leaking.

From what I gather on the forums, this sound like the damper plate is worn out. Any suggestions?

Thanks,
Drew
Reply With Quote
  #2  
Old 07-26-2020, 11:28 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 966
Make sure the tranny oil is full. Tranny oil never gets black, it always looks good because its not contaminated by engine combustion. Should probably change it out also. There is a tranny oil filter also that you can clean.
Reply With Quote
  #3  
Old 07-26-2020, 11:55 PM
Torchwork Torchwork is offline
TT Newbie
 
Join Date: Jul 2020
Boat: Mastercraft x45 2005 8.1
Location: Southeast
Posts: 10
Thanks,
The tranny oil is full and doesn't smell like it's been cooked. I'll check the filter. The boat was well maintained, and I'm the second owner.
Reply With Quote
  #4  
Old 07-27-2020, 04:15 PM
Torchwork Torchwork is offline
TT Newbie
 
Join Date: Jul 2020
Boat: Mastercraft x45 2005 8.1
Location: Southeast
Posts: 10
Filter looked good. I cleaned it with brake cleaner and compressed air, once dry I reinstalled. I'm wondering if its the damper plate or something else in there. It also looks like it was swapped over to oil instead of atf, looks like honey.
Reply With Quote
  #5  
Old 07-27-2020, 04:46 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 966
fluid spec for that transmission is 15W-40 oil. There should be sticker next to the dip stick that says what to use.

Last edited by tr6coug; 07-27-2020 at 10:22 PM.
Reply With Quote
  #6  
Old 07-27-2020, 05:58 PM
Torchwork Torchwork is offline
TT Newbie
 
Join Date: Jul 2020
Boat: Mastercraft x45 2005 8.1
Location: Southeast
Posts: 10
That makes a lot of sense, I thought it was atf but it was just the dip sticks color. It's starting to sound like the clutch pack is on its way out.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:05 AM.


2020