Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-28-2020, 01:39 PM
TheDudeMC's Avatar
TheDudeMC TheDudeMC is offline
TT Newbie
 
Join Date: Jul 2017
Boat: 2001 X-Star, LTR
Location: Midwest
Posts: 9
Off idle engine issues, MCX engine

Just recently Installed a new long block from Michigan motorz in a 03 x-30. Engine runs great other than it falls on its face on a slow off idle acceleration. If you accelerate fast like youíre pulling up a wakeboarded itís great. Iíve checked fuel pressure, timing, pulled manifold and resealed and I canít seem to figure out the issue. Anyone had similar issues and figured out the problem, maybe the IAC?? Thanks in advance!
__________________
2001 X-Star 330 LTR (under restoration)

Last edited by TheDudeMC; 07-28-2020 at 01:53 PM. Reason: Spelling
Reply With Quote
  #2  
Old 07-28-2020, 01:40 PM
CruisinGA's Avatar
CruisinGA CruisinGA is offline
MC Devotee
 
Join Date: Jun 2009
Boat: '01 X9 330HP
Location: Georgia
Posts: 2,432
throttle position sensor?
__________________
Bailey
'02 X-9
Lake Blue Ridge
Reply With Quote
  #3  
Old 07-28-2020, 01:47 PM
TheDudeMC's Avatar
TheDudeMC TheDudeMC is offline
TT Newbie
 
Join Date: Jul 2017
Boat: 2001 X-Star, LTR
Location: Midwest
Posts: 9
I thought that possibly too but I hate to keep throwing money at it without knowing a little better what’s up! Wish I had a computer to hook to it!!
__________________
2001 X-Star 330 LTR (under restoration)
Reply With Quote
  #4  
Old 07-28-2020, 03:44 PM
TheDudeMC's Avatar
TheDudeMC TheDudeMC is offline
TT Newbie
 
Join Date: Jul 2017
Boat: 2001 X-Star, LTR
Location: Midwest
Posts: 9
New IAC didn’t help...
__________________
2001 X-Star 330 LTR (under restoration)
Reply With Quote
  #5  
Old 07-29-2020, 12:10 PM
curver900 curver900 is offline
MC Maniac
 
Join Date: Aug 2013
Boat: Mastercraft, prostar 2001 205v
Location: midwest
Posts: 2,705
sometimes it is cheaper to go to the dealer, go to the lake, plug in the computer and see what is wrong... throwing parts always costs more than a proper diagnostics....
Reply With Quote
  #6  
Old 07-29-2020, 01:06 PM
TheDudeMC's Avatar
TheDudeMC TheDudeMC is offline
TT Newbie
 
Join Date: Jul 2017
Boat: 2001 X-Star, LTR
Location: Midwest
Posts: 9
Plugged it in today, no codes and everything looks good. Really odd. Oh and our dealer isnít worth the phone call unfortunately...
__________________
2001 X-Star 330 LTR (under restoration)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:51 AM.


2020