Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 08-22-2019, 06:18 PM
zilk zilk is offline
TT Newbie
 
Join Date: Apr 2018
Boat: 2012 Mastercraft X35
Location: Lake Norman
Posts: 5
It's either running or NOT

hey all - 2012 Mastercraft X35. Last weekend decided to either have full voltage or nothing. It happened at the dock and on the lake. Literally would stop running like a major wire harness was pulled from the motor. I replaced the batteries because my tech told me that they're very picky about them, but no change. It will sometimes start right up, and run for awhile and then simply die. The gauges would show either full battery or "1.1 volts". There is nothing abnormal about it when it's running.

Really would appreciate any ideas on where to start looking. It scared the crap out of me when it just died while idling - and of course the wind was blowing hard and pushing me right toward a rocky shore. Fortunately my son was out on the jetski and pulled me to the dock.
Reply With Quote
  #2  
Old 08-22-2019, 06:54 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 911
Sounds like an intermittent connection in you battery cables. I'd start by going through all of the battery cables and making sure they are all tight. If you have a battery switch make sure those connections are tight. Check at the starter where the positive battery cable connects to the solenoid. Check your ground points. Look for corrosion at connection points.
__________________
'07 Navy Blue X2 MCX
http://www.wakeblaster.com/
Ballast Timer Reprogramming Info
Reply With Quote
  #3  
Old 08-22-2019, 08:36 PM
zilk zilk is offline
TT Newbie
 
Join Date: Apr 2018
Boat: 2012 Mastercraft X35
Location: Lake Norman
Posts: 5
That makes sense - much appreciated!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:52 PM.


2018