Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-16-2020, 01:04 AM
Saunders08 Saunders08 is offline
TT Newbie
 
Join Date: Aug 2019
Boat: 2002 X-9
Location: West Coast
Posts: 14
2018 XStar wakeboard setting

I just got a 2018 XStar 50th Anniversary edition. When I put it in advanced wakeboard setting or intermediate setting the boat will not go over 13 mph. Iím at a lake thatís at 5100 foot elevation. Dealer said it could be a prop issue. Anyone have this issue?
Reply With Quote
  #2  
Old 07-16-2020, 09:01 AM
badinlake badinlake is offline
TT Regular
 
Join Date: Mar 2020
Boat: 2019 X-Star
Location: southeast
Posts: 33
What is your weight distribution? I haven't had an issue that it won't go over 13 at all, but coming out of a turn, if I have fully loaded, I have seen it struggle. 2 things have helped there - first, send more people to the front. Second, deploy the center tab until speed comes up. I'm running at a much lower elevation - and have used both the stock and the ACME 3289.

Side note on probs - I noticed the ACME 3289 is definitely higher speed/lower RPM, but struggles a bit more under heavy loads.
Reply With Quote
  #3  
Old 07-16-2020, 09:25 AM
csherbo's Avatar
csherbo csherbo is offline
TT Enthusiast
 
Join Date: Jan 2014
Boat: 2020 XStar
Location: Austin, Texas
Posts: 354
Are you enabling Triple Tab Auto Launch? Pretty essential if you are running full ballast.
Reply With Quote
  #4  
Old 07-16-2020, 12:25 PM
Saunders08 Saunders08 is offline
TT Newbie
 
Join Date: Aug 2019
Boat: 2002 X-9
Location: West Coast
Posts: 14
Yes running the triple launch. Didnít change anything on the over all speed. Definitely better getting out of the water.
Reply With Quote
  #5  
Old 07-16-2020, 01:00 PM
WakeRider107 WakeRider107 is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: boat
Location: location
Posts: 240
Quote:
Originally Posted by Saunders08 View Post
Yes running the triple launch. Didnít change anything on the over all speed. Definitely better getting out of the water.
I'm confused - so you are getting on plane or not at all even with triple autolaunch?
Reply With Quote
  #6  
Old 07-16-2020, 01:04 PM
Saunders08 Saunders08 is offline
TT Newbie
 
Join Date: Aug 2019
Boat: 2002 X-9
Location: West Coast
Posts: 14
I’m getting on plane with the triple launch but it won’t get over 13 MPH. Dealer thinks it’s a prop issue because of altitude. Doesn’t really make sense to me how it is fine in all other setting. Maybe because to much ballast weight?
Reply With Quote
  #7  
Old 07-16-2020, 01:19 PM
WakePowell WakePowell is offline
MC Fanatic
 
Join Date: Oct 2004
Boat: Mastercraft X-Series
Location: Te-X-as
Posts: 515
Try this. Select wakeboard intermediate and let the ballast fill. Then select drive and disable the speed control. See if you can then get it on plane and to speed. If so, there may be something a miss with your speed control.

Additionally, whenever I have had an issue. I turn the ignition off and then turn the battery off. Let the boat sit for a few minutes then turn on the battery and then the ignition. Often this reboot works.
Reply With Quote
  #8  
Old 07-16-2020, 03:26 PM
Saunders08 Saunders08 is offline
TT Newbie
 
Join Date: Aug 2019
Boat: 2002 X-9
Location: West Coast
Posts: 14
Thanks I will give this a try!!
Reply With Quote
  #9  
Old 08-17-2020, 04:38 PM
badinlake badinlake is offline
TT Regular
 
Join Date: Mar 2020
Boat: 2019 X-Star
Location: southeast
Posts: 33
Just a belated follow-up post to this.. I have found w/ a full load of people that the weight distribution, startup speed and using the tabs are all key - or else you can get stuck @ 13MPH and not get up to plane...

First - yes, use the triple launch setting

Second - hit it hard and work to get up to speed fast. Don't bother trying to do a gentle start.

Third - you may need to move some people to the front at start, then move to back when @ plane

Fourth - manually deploying the center tab while trying to come to speed (after auto launch shuts off) can help

and Fifth - this is a new one, I have found the X-Star doesn't like the weight distribution w/ the stadium seating setup when I have a full boat. It also sometimes struggles to get a clean wake w/ stadium seating pulled out. When I say full boat, I had full ballast and 13 adults on the boat.
Reply With Quote
  #10  
Old 08-17-2020, 04:44 PM
eecyclone eecyclone is offline
MC Fanatic
 
Join Date: Oct 2014
Boat: 2018 XT22
Location: Omaha NE
Posts: 911
I ran an X-star with full ballast and 11 adults and never had any issues getting on plane. The 6.2 with 2:1 transmission made it feel easy.

What are you triple autolaunch settings? I want to say the side tabs should be at 15-17mph and the center tab at 19-20 mph. If they're retracting too early then they aren't helping you to get up to speed.
__________________
'18 XT22 w/5500 & Upgraded Premium Stereo
(Previous- '08 X2 w/MCX)
'16 F150 Platinum Screw 3.5L Eco 4x4

I can help with Klispch Stereo modifications
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:25 AM.


2020