Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-31-2018, 04:52 PM
AVPdx AVPdx is offline
TT Regular
 
Join Date: Feb 2017
Boat: 2018 X23, prev 2017 XT20
Location: Northwest
Posts: 44
2018 trailer wheel bearing cap failure

I have towed my 2018 X23 aprox 300 miles since new this spring. Last week on the way home from the lake I noticed lubricant leaking out of the center hub cover on the rear wheel of the trailer. I removed the cap covering the lug nuts and found the cap for the wheel hub that houses the bearings was rolling around loose in the hub cover. All of the bearing lubricant had leaked out. Took off the hub cover on the opposite side and the cap had come loose on that side also, and was leaking lube. Called the dealer and they said not to tow the boat as the bearings could seize up if there is insufficient lube.

The tech came out today to replace the bearing caps and found that the rubber O ring that goes between the cap and hub had failed. All four wheel hubs had broken O rings. He said that he has seen a number of 2018 trailers with this problem as the caps were over tightened at the factory causing the O ring to break. These are the Vortex brand hub kit.

Its worth going and checking the O rings on the hubs if you have a 2018 trailer. If the O ring is cracked or broken then the cap will work itself loose and the lube will leak out. I'm going to buy some spares in case it happens when I'm on a trip.

This is the part- https://trailerpartssource.com/TIE-D...iABEgJZw_D_BwE
Reply With Quote
  #2  
Old 07-31-2018, 05:23 PM
uplandbird uplandbird is offline
MC Devotee
 
Join Date: Aug 2014
Boat: 2018 X23 6000GDI - Previous 2014 Gen2 X25 6.0L
Location: Kansas City
Posts: 1,263
When did you take delivery of your 2018?
Reply With Quote
  #3  
Old 07-31-2018, 06:53 PM
AVPdx AVPdx is offline
TT Regular
 
Join Date: Feb 2017
Boat: 2018 X23, prev 2017 XT20
Location: Northwest
Posts: 44
Quote:
Originally Posted by uplandbird View Post
When did you take delivery of your 2018?
May 2018. The tech thought the majority of 2018 boat trailers have the Vortex hubs
Reply With Quote
  #4  
Old 07-28-2020, 01:23 PM
JulioX2's Avatar
JulioX2 JulioX2 is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: XT-22 5.3L 5500GDI
Location: Alberta, Canada
Posts: 209
Quote:
Originally Posted by AVPdx View Post
I have towed my 2018 X23 aprox 300 miles since new this spring. Last week on the way home from the lake I noticed lubricant leaking out of the center hub cover on the rear wheel of the trailer. I removed the cap covering the lug nuts and found the cap for the wheel hub that houses the bearings was rolling around loose in the hub cover. All of the bearing lubricant had leaked out. Took off the hub cover on the opposite side and the cap had come loose on that side also, and was leaking lube. Called the dealer and they said not to tow the boat as the bearings could seize up if there is insufficient lube.

The tech came out today to replace the bearing caps and found that the rubber O ring that goes between the cap and hub had failed. All four wheel hubs had broken O rings. He said that he has seen a number of 2018 trailers with this problem as the caps were over tightened at the factory causing the O ring to break. These are the Vortex brand hub kit.

Its worth going and checking the O rings on the hubs if you have a 2018 trailer. If the O ring is cracked or broken then the cap will work itself loose and the lube will leak out. I'm going to buy some spares in case it happens when I'm on a trip.

This is the part- https://trailerpartssource.com/TIE-D...iABEgJZw_D_BwE
I'm literally just going through the exact same problem. Towed my 2018 XT-22 through the rocky mountains for the first time since I bought it new. My dealership wasn't really helpful when I tried getting some help/advice from them. It's in the shop currently getting fixed.
I'm just wondering if they just replaced your O-rings and caps, or if was something else? Have you had any issues since they fixed it?
Thanks!
Reply With Quote
  #5  
Old 07-28-2020, 01:30 PM
Tony84121
Guest
 
Posts: n/a
Had a similar problem with my 2018; although mine, the rear axle bearings were incorrect. Only found this out when I was bleeding the trailer brakes, and lifted the rear wheel, and noticed considerable play. After working with corporate MC, Corporate shipped 2 replacement hubs/spindles for my dealer to then have installed. Could have been a disaster had I not found the issue!
Reply With Quote
  #6  
Old 07-28-2020, 01:52 PM
SurfIowa SurfIowa is offline
TT Newbie
 
Join Date: Jun 2020
Boat: 2018 X23
Location: Midwest
Posts: 7
I had similar issues last summer with X23 trailer. Replaced all hubs and seems to be ok now.
Reply With Quote
  #7  
Old 07-28-2020, 02:14 PM
WakePowell WakePowell is offline
MC Fanatic
 
Join Date: Oct 2004
Boat: Mastercraft X-Series
Location: Te-X-as
Posts: 515
I will chime in, my 2018 trailer had the same issue.
Reply With Quote
  #8  
Old 07-28-2020, 02:32 PM
edwin edwin is offline
TT Enthusiast
 
Join Date: Aug 2004
Boat: 2016 X30, 6.2L
Location: Midwest
Posts: 121
Had the same issue with my 2016 trailer. I bought the vortex replacement covers and installed them myself...wasn't worth the time to drag the trailer to the dealer for a 5 minute fix.
Reply With Quote
  #9  
Old 07-28-2020, 02:39 PM
WolverineFW WolverineFW is offline
TT Regular
 
Join Date: Mar 2020
Boat: 2018 Mastercraft XT21
Location: Western Canada
Posts: 53
I just had the same issue with my 2018 trailer that I towed for the first time a couple weeks ago.

Sent from my SM-G965W using Tapatalk
Reply With Quote
  #10  
Old 07-28-2020, 03:44 PM
eecyclone eecyclone is offline
MC Fanatic
 
Join Date: Oct 2014
Boat: 2018 XT22
Location: Omaha NE
Posts: 910
Almost 7,000 miles of towing my 2018 trailer and I haven't had any issues (knock on wood)
__________________
'18 XT22 w/5500 & Upgraded Premium Stereo
(Previous- '08 X2 w/MCX)
'16 F150 Platinum Screw 3.5L Eco 4x4

I can help with Klispch Stereo modifications
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:38 AM.


2020