Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-31-2020, 06:48 AM
Francois Francois is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2007 Mastercraft X2
Location: Canada
Posts: 12
whistle noise in transmission mcx 350

Whatsup guys

So yesterday i cleaned my K&N Flame arestor on my 2007 X2. It was really dirty ! I used the K&N cleaning and oiling product and it worked great!

The next day i put the boat in the water and when i shift from neutral to forward or reverse, i heard a squealing sound like a whistle that last 1 sec and then it stopped. like if something was not lubricate.

Doesnt affect anything else except my ear.

I checked the transmission oil and the motor oil and its good.

You guys have any clue?

https://www.facebook.com/francoisfla...63890848800484

Thanks

Last edited by Francois; 07-31-2020 at 07:23 AM. Reason: adding video
Reply With Quote
  #2  
Old 07-31-2020, 07:19 AM
gwozhog's Avatar
gwozhog gwozhog is offline
MC Devotee
 
Join Date: Jul 2013
Boat: Achilles sg124
Location: south
Posts: 1,227
Record a video next time your out
Reply With Quote
  #3  
Old 07-31-2020, 07:24 AM
Francois Francois is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2007 Mastercraft X2
Location: Canada
Posts: 12
https://www.facebook.com/francoisfla...63890848800484

Here it is
Reply With Quote
  #4  
Old 07-31-2020, 12:48 PM
motomario motomario is offline
TT Newbie
 
Join Date: Jan 2019
Boat: x30 2001
Location: russia
Posts: 29
Check the belt alternator tension.Check the alternator belt tension. My boat had that sound. I pulled on the generator belt and cleaned the pulleys
Reply With Quote
Reply

Tags
mcx indmar 5.7l, x2 2007

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:32 AM.


2020