Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #71  
Old 06-10-2019, 01:21 PM
forcel0 forcel0 is offline
TT Regular
 
Join Date: Sep 2016
Boat: 2009 CSX 220 Saltwater Series
Location: Southeast
Posts: 79
As long as it has power it will light based the model number ordered at the time

https://www.carlingtech.com/toggle-switches-lt-series

If you followed the relay diagram where your switch is switching the +12VDC then the lamp goes to ground. If you are switching the ground then the lamp needs to go to +12VDC.
__________________
Present
2009 CSX 220 SS
Past
1999 Maristar 210 VRS LTR
Reply With Quote
  #72  
Old 01-29-2020, 05:17 PM
Francois Francois is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2007 Mastercraft X2
Location: Canada
Posts: 12
Hi skeeler
I plan to do this on my x2 2007. What type of relay did you use? Does it need a specific type of relay?

Thanks
Reply With Quote
  #73  
Old 01-29-2020, 07:43 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 991
Quote:
Originally Posted by Francois View Post
Hi skeeler
I plan to do this on my x2 2007. What type of relay did you use? Does it need a specific type of relay?

Thanks
He's been gone for several years, but any automotive style 12V 30A relay should work. Some come with mounting tabs so you can screw them down to a panel. Here is an example of some waterproof relays from Amazon. You can get this style relay at any automotive store.

Relay Link
Reply With Quote
  #74  
Old 02-02-2020, 12:30 AM
Francois Francois is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2007 Mastercraft X2
Location: Canada
Posts: 12
Allright thanks man!
Reply With Quote
  #75  
Old 04-04-2020, 06:25 PM
Francois Francois is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2007 Mastercraft X2
Location: Canada
Posts: 12
Quote:
Originally Posted by Bmarine View Post
I just did this bypass on a 2008 X1 2 relays per pump works great.
Question: Did yall figure out what to do with the green LED wire?
I'd like to hook it up if I can.
Hi bmarine
Do you have a picture of your work? i tried this to but it doesnt work. does the ground and the power need to be connect with a buss bar?

Thanks
Reply With Quote
  #76  
Old 04-04-2020, 07:10 PM
snork snork is offline
MC Maniac
 
Join Date: Jul 2007
Boat: 07 xstar
Location: south
Posts: 3,128
Skeeler
Reply With Quote
  #77  
Old 04-07-2021, 10:13 PM
igormaster igormaster is offline
TT Enthusiast
 
Join Date: Aug 2015
Boat: Mastercraft, X2, X45, X25
Location: Mountains
Posts: 186
LED light issue

I just put together demo version of two relay per pump system based on the diagrams posted. Everything works! the LED wire is connected to power wire on the switch just as it is on original set up on ballast 3 gauges panel (2007 X45). The RED LED on the switch is always on, since there is no controller to tell it to go on only when the switch is turned to fill or drain. So the LED is always on; just showing that there is power to the ballast system. It stays on whether i fill drain or in the middle position. It will work for me. I will take pictures when i put everything in the original box. As as side note i have three controller boxes for sale (two [programmed by TR6 cougar and one just purchased from wakemakers A1 type I am sure they are all fine for what they are intended but i am done with artificial intelligence; i want on, off, and reverse). Will let em go all three for $150 if any takers.
igor
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:14 AM.


2020