Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 09-10-2019, 03:22 PM
CF-maristar215 CF-maristar215 is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2010 Maristar 215V
Location: Canada
Posts: 3
Engine/display screen shutting down intermittently

--------------------------------------------------------------------------------

I have a 2010 maristar 215V with about 175hrs and have been having some issues with the boat shutting down without warning. I can pull 3 skiers and go 30mph or cruise around with no problem. Several times with port and aft ballasts more or less full, while wakesurfing and going about 11mph, the engine will quit, display will beep and shut down. Its done it several times and there is no indicator when it will happen. Sometimes we surf with the same config and nothing will happen. I've reconnected the battery, checked the software for engine faults, etc. but it shows nothing. HELP!! Any thoughts??
Reply With Quote
  #2  
Old 09-10-2019, 04:35 PM
Shaun R's Avatar
Shaun R Shaun R is online now
MC Devotee
 
Join Date: Jun 2014
Boat: 2011 X25
Location: Austin, Texas
Posts: 1,980
Have you checked your kill switch to make sure it’s not the issue? I have a similar setup and accidentally bumped mine the other day and it shut down exactly as you mentioned. It wasn’t hard enough of a bump to knock it off, but it was just enough to shut everything down.
Reply With Quote
  #3  
Old 09-11-2019, 01:38 PM
CF-maristar215 CF-maristar215 is offline
TT Newbie
 
Join Date: Sep 2019
Boat: 2010 Maristar 215V
Location: Canada
Posts: 3
Will double check that. Thanks!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:45 PM.


2018