Announcement

Collapse
No announcement yet.

Backing down trailer and brakes act weird

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Backing down trailer and brakes act weird

    This is a very weird reaction on my '16 Yukon. I have towed many boats and this is a first. Trailering my boat to the lake my brakes feel normal and have a spongy feel which is like your driving your car normal. When backing down my boat on the ramp its normal until my trailer tongue is fully expanded out because gravity is pulling the boat away. When its fully expanded my brakes feel very hard and the spongy feel is gone and my brakes don't work near as good and its kind of not safe. Any ideas? I have a '13 boatmate trailer with a new ufp a60 hitch on it.

    Sent from my SAMSUNG-SM-G930A using Tapatalk

  • #2
    Also put this in the wrong category. Is there a way to move it?

    Sent from my SAMSUNG-SM-G930A using Tapatalk

    Comment


    • #3
      I’m guessing here....but maybe it’s your antilock brakes?
      - Andrew

      2015 MasterCraft X-20 (current)
      2009 MasterCraft X-2 (sold)

      Comment


      • #4
        Originally posted by ap77 View Post
        I’m guessing here....but maybe it’s your antilock brakes?
        I've had numerous Suvs and all had anti lock brakes and this is first one that's ever done it. I pulled a '12 X25 and it didn't do it. It also had a boatmate trailer with the UFP a60 hitch

        Sent from my SAMSUNG-SM-G930A using Tapatalk

        Comment


        • #5
          Sounds like the hill start system not disengaging when the trucks in reverse

          Comment


          • #6
            Originally posted by Atver300 View Post
            Sounds like the hill start system not disengaging when the trucks in reverse
            That could be something. Ill look into that.

            Sent from my SAMSUNG-SM-G930A using Tapatalk

            Comment


            • #7
              Originally posted by Atver300 View Post
              Sounds like the hill start system not disengaging when the trucks in reverse
              That's a great guess, maybe put it in tow mode or take it out of tow mode. Hill start needs to auto turn off in reverse regardless I would think. Does it only happen when the trailer is hooked up? 7 pin harness? Only backing downhill or uphill too?
              boats rock, but don't rock the boat

              Comment


              • #8
                Originally posted by trunderw View Post
                That's a great guess, maybe put it in tow mode or take it out of tow mode. Hill start needs to auto turn off in reverse regardless I would think. Does it only happen when the trailer is hooked up? 7 pin harness? Only backing downhill or uphill too?
                Only does it when backing down my boat on a ramp. It does have a 7 pin

                Sent from my SAMSUNG-SM-G930A using Tapatalk

                Comment


                • #9
                  I've had similar issues in the past and it was all related to the reverse solenoid (mine was a bad ground wire). Check out this website, specifically look at the FAQs in the brake section. They have troubleshooting guides for this specific issue.

                  http://www.boatmateparts.com/faqs.php#28

                  Comment

                  Working...
                  X