Announcement

Collapse
No announcement yet.

2007 X Star will not crank...Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2007 X Star will not crank...Help

    So, I have a 2007 xstar with the 5.7 MCX engine the cut of on me the other day and will not start back. The code in the boat said throttle body. I have replaced the fuel pump as well as the throttle body, as that seemed to be the problem from reading the forums on here. No luck....engine turns over fine, but will not fire up. Tested the ingnition switch and check all of my connections, all seemed to be fine. Please help!

  • #2
    safety lanyard ???

    Comment


    • #3
      That would suck if that's all it was...

      Comment


      • #4
        Sounds a lot like the safety switch/ lanyard
        Screws fall out all the time, the world is an imperfect place.

        Comment


        • #5
          gauges cycle?
          2017 Mastercraft XT21- Black & Calypso Green Flake and Coolfeel interior

          2008 Mastercraft 40th Anniversary X-star SOLD

          1981 J-craft 19 long deck ski boat w/200 Mercury Black Max (the gas guzzler)

          2018 Audi Q7 Technik Navarra Blue with S-Line, Black Optics, Luxury package, advanced driver assistance, Audi Sport 21" wheels, tow hitch

          Comment


          • #6
            Safety lanyard is fine. All the gauges will work the batteries are less than a month old and are fully charged. Warning beeper went off when I pulled it in last and check engine light came on saying throttlebody code. So I put a brand-new one on it had the Mastercraft mechanic come out still nothing.

            Comment


            • #7
              All gauges work fine.

              Comment


              • #8
                Are you getting spark? Also check for fuel at the rail valve.
                We defy the mafia!

                Comment


                • #9
                  Fuel rail has plenty of pressure and I am getting spark.

                  Comment


                  • #10
                    Originally posted by CHRISQ View Post
                    Fuel rail has plenty of pressure and I am getting spark.
                    You checked the fuel pressure with a gauge I assume? Where did you test the spark -- at a plug or at the dizzy?
                    2005 X2, Viper Red, MCX, Acme 1285, PPass, rear 750 sacs, KBS, IBS, Bennett Wake Plate
                    (previous) 2001 X5, 1991 TriStar 190

                    Comment


                    • #11
                      If you got a pedal code too it could be the transmission temperature sensor. I'm dealing with these same issues on my 07 xstar LY6. Getting the part today - hoping it resolves all my issues. Did you pick up the throttle body online or through the dealer? That'll be my next move if this doesn't work. As others have said make sure you have the big three, fuel (check on the rail with a gauge), spark (check after the plug), and air (hoping your new throttle body is perfect, but always worth checking via the ECM it should show a low % when closed and high % when open)


                      Sent from my iPhone using Tapatalk

                      Comment


                      • #12
                        The fuel was tested with a fuel guage and spark was check from a plug by a mastercraft mechanic.

                        Comment


                        • #13
                          You sure it says throttle body? It could be that you're in gear, or the boat thinks your in gear. If the lanyard is bad it will crank but never turn over - if it's in gear it won't crank at all

                          Comment


                          • #14
                            Yes, the code said throttle body per the mastercraft tech.

                            Comment


                            • #15
                              Something doesn't add up here. If it:

                              1. Has fuel
                              2. Has spark

                              Then it will start unless the timing is way off. That's unlikely given it's electronic ignition. I'd verify that it really does have spark and if not, bypass the lanyard switch first to eliminate that.
                              2008 40th Xstar
                              2006 ProStar 197 - sold
                              1992 Ski Nautique
                              1969 Glastron

                              Comment

                              Working...
                              X