Announcement

Collapse
No announcement yet.

2018 trailer wheel bearing cap failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2018 trailer wheel bearing cap failure

    I have towed my 2018 X23 aprox 300 miles since new this spring. Last week on the way home from the lake I noticed lubricant leaking out of the center hub cover on the rear wheel of the trailer. I removed the cap covering the lug nuts and found the cap for the wheel hub that houses the bearings was rolling around loose in the hub cover. All of the bearing lubricant had leaked out. Took off the hub cover on the opposite side and the cap had come loose on that side also, and was leaking lube. Called the dealer and they said not to tow the boat as the bearings could seize up if there is insufficient lube.

    The tech came out today to replace the bearing caps and found that the rubber O ring that goes between the cap and hub had failed. All four wheel hubs had broken O rings. He said that he has seen a number of 2018 trailers with this problem as the caps were over tightened at the factory causing the O ring to break. These are the Vortex brand hub kit.

    Its worth going and checking the O rings on the hubs if you have a 2018 trailer. If the O ring is cracked or broken then the cap will work itself loose and the lube will leak out. I'm going to buy some spares in case it happens when I'm on a trip.

    This is the part- https://trailerpartssource.com/TIE-D...iABEgJZw_D_BwE

  • #2
    When did you take delivery of your 2018?

    Comment


    • #3
      Originally posted by uplandbird View Post
      When did you take delivery of your 2018?
      May 2018. The tech thought the majority of 2018 boat trailers have the Vortex hubs

      Comment


      • #4
        Originally posted by AVPdx View Post
        I have towed my 2018 X23 aprox 300 miles since new this spring. Last week on the way home from the lake I noticed lubricant leaking out of the center hub cover on the rear wheel of the trailer. I removed the cap covering the lug nuts and found the cap for the wheel hub that houses the bearings was rolling around loose in the hub cover. All of the bearing lubricant had leaked out. Took off the hub cover on the opposite side and the cap had come loose on that side also, and was leaking lube. Called the dealer and they said not to tow the boat as the bearings could seize up if there is insufficient lube.

        The tech came out today to replace the bearing caps and found that the rubber O ring that goes between the cap and hub had failed. All four wheel hubs had broken O rings. He said that he has seen a number of 2018 trailers with this problem as the caps were over tightened at the factory causing the O ring to break. These are the Vortex brand hub kit.

        Its worth going and checking the O rings on the hubs if you have a 2018 trailer. If the O ring is cracked or broken then the cap will work itself loose and the lube will leak out. I'm going to buy some spares in case it happens when I'm on a trip.

        This is the part- https://trailerpartssource.com/TIE-D...iABEgJZw_D_BwE
        I'm literally just going through the exact same problem. Towed my 2018 XT-22 through the rocky mountains for the first time since I bought it new. My dealership wasn't really helpful when I tried getting some help/advice from them. It's in the shop currently getting fixed.
        I'm just wondering if they just replaced your O-rings and caps, or if was something else? Have you had any issues since they fixed it?
        Thanks!

        Comment


        • #5
          Had a similar problem with my 2018; although mine, the rear axle bearings were incorrect. Only found this out when I was bleeding the trailer brakes, and lifted the rear wheel, and noticed considerable play. After working with corporate MC, Corporate shipped 2 replacement hubs/spindles for my dealer to then have installed. Could have been a disaster had I not found the issue!

          Comment


          • #6
            I had similar issues last summer with X23 trailer. Replaced all hubs and seems to be ok now.
            _____________________________________________
            2019 X22
            2018 X23

            Comment


            • #7
              I will chime in, my 2018 trailer had the same issue.
              2005 X45
              2009 X45
              2018 X46
              2022 XStar-S

              Comment


              • #8
                Had the same issue with my 2016 trailer. I bought the vortex replacement covers and installed them myself...wasn't worth the time to drag the trailer to the dealer for a 5 minute fix.

                Comment


                • #9
                  I just had the same issue with my 2018 trailer that I towed for the first time a couple weeks ago.

                  Sent from my SM-G965W using Tapatalk

                  Comment


                  • #10
                    Almost 7,000 miles of towing my 2018 trailer and I haven't had any issues (knock on wood)
                    '18 XT22 w/5500 & Upgraded Premium Stereo
                    (Previous- '08 X2 w/MCX)
                    '16 F150 Platinum Screw 3.5L Eco 4x4

                    I can help with Klipsch Stereo modifications
                    www.chesnuttech.com

                    Comment


                    • #11
                      Kind of surprised at how many people have had the same issue. More than I would have thought.

                      Comment


                      • #12
                        Originally posted by JulioX2 View Post
                        Kind of surprised at how many people have had the same issue. More than I would have thought.
                        same!

                        Comment


                        • #13
                          Well now I'm nervous. Haven't had any issues with mine.

                          Comment


                          • #14
                            One of my caps was broken. My dealer gave me one. I check them very often now. I wasn't aware of the bearing issue. I will have to jack mine up and check for play. I would think you would see some tire wear maybe.

                            Comment


                            • #15
                              For as bad as the bearing issue was, there was zero tire wear to indicate a problem with mine. I was very surprised!

                              Comment

                              Working...
                              X