Announcement

Collapse
No announcement yet.

2015 X25 -Bags not holding water

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2015 X25 -Bags not holding water

    2015 X25Yesterday I filled up all the ballast including the bags in the rear lockers. With Gen 2 its done with the push of a button. Surfed for about 45 minutes then noticed we didn't have the wave as at the start of the session. Looked into the back lockers and both bags had lost between 1/4 and 1/2 of the water. Didn't seem to be a leak anywhere. And with it being both bags I'm guessing they are draining somehow. Any thoughts on what is happening?

    Also, can I not just fill them back up somehow? Or do I have to drain everything using the computer screen and fill them all back up again. I'm not sure how the rear lockers can be filled on their own as I believe the computer fills everything at the same time??? HELP!!

  • #2
    My 15 X25 had a cracked tank. Had the same symptoms however the diagnosis was simple. The Bilge ran like crazy.

    Both bags is odd. Wouldn't think both tanks would crack.

    Possible your pumps have an issue. Maybe they are spinning in reverse under the pressure of the full load of ballast?

    Comment


    • #3
      Is there a way I can just fill the bags back up once they start to lose water?

      Comment


      • #4
        If it's plug-n-play, don't you have manual switches to fill and empty on a 30 second timer? Just run those until they fill again.

        Comment


        • #5
          I do have manual switches but are those not for the hard tanks only? Sorry if I'm asking stupid questions. First year with a real boat.

          Comment


          • #6
            Gravity fed from the bag to the hard tank. Run the manual switches. Should work.

            Comment


            • #7
              If I did happen to have a leak in the hard tank what is the process to have that looked at and fixed? Sounds like a huge job and $$$$

              Comment


              • #8
                If your bilge is running constantly, you definitely have a leak. Otherwise, it might just be a gravity or pump leak issue and you need to manually fill for 30-60 secs between riders. No biggie.

                Plus, 2015 MC should still be under warranty if you have hard tank issues...

                Comment


                • #9
                  Originally posted by Johnnywang View Post
                  If I did happen to have a leak in the hard tank what is the process to have that looked at and fixed? Sounds like a huge job and $$$$
                  It could be that you are just losing water from the vent/drain if the bags are big for the compartment. But to answer your question, they lift the top deck of the boat from the hull by removing the rub rail and unscrewing it / unplugging all the wiring. If your boat is only 4 years old, this is a warranty issue. MC will replace all tanks if you have to split it, even if you only have one leaking. It is expensive. I've seen it done by a guy down here in AL. MC sends him several a year.

                  Comment


                  • #10
                    Thanks for the comments. The bilge is not running constantly so shouldn't be a leak. If I had to guess its more of a gravity thing.

                    Comment


                    • #11
                      Have also seen bags loose water over time if the ballast pump impellers are getting worn. Water can slowly seep past the impellers as they do not seal against the pump housing as well as they do when new. If so a couple new green ballast pump impellers from Wakemakers.com may just do the trick.

                      Until then just hit the 30 sec pump fill switches between riders and watch for water to dump out the overflow vent so you know the bags are full.
                      XT20 5500 GDI Black Mica/Black Topdeck/ Black interior
                      SOLD - 2013 X2 Pro Pkg, Gen2 Surf
                      SOLD - 1998 30th Anniversary ProStar 190
                      SOLD - 1985 Stars and Stripes

                      sigpic

                      Comment


                      • #12
                        Originally posted by Johnnywang View Post
                        2015 X25Yesterday I filled up all the ballast including the bags in the rear lockers. With Gen 2 its done with the push of a button. Surfed for about 45 minutes then noticed we didn't have the wave as at the start of the session. Looked into the back lockers and both bags had lost between 1/4 and 1/2 of the water. Didn't seem to be a leak anywhere. And with it being both bags I'm guessing they are draining somehow. Any thoughts on what is happening?

                        Also, can I not just fill them back up somehow? Or do I have to drain everything using the computer screen and fill them all back up again. I'm not sure how the rear lockers can be filled on their own as I believe the computer fills everything at the same time??? HELP!!
                        did you verify that the bags were full to start with... do you know that the bags lost water, or did they just not fill up all the way to begin with?

                        anyhow, as your ballast impellers wear- you may need to add additional time onto the pump fill/drain times. This is done through the menu screen under ballast/tab settings. I found that as the season went on, I would add 10 seconds or so to fill times in order to keep bags full.

                        Also, as your ballast impellers wear out, they can let water by, and allow the bags to siphon out. This causes the bags to lose water but not leak into the boat. If your impellers have a few years or 100+ hours on them, you probably need to replace them.

                        as mentioned, the manual switches can be used to override and turn the pumps on. Flip the switch and it runs for 30 seconds, turn it off, then you can turn it back on and run for another 30 seconds. Both the hard tank and the bag share the same pump, so when you turn the pump on you are filling both - but the hard tank fills up first and then once it is full it overflows into the bag.
                        The question is not whether life exists after death, but whether you were alive before death - Osho

                        Comment


                        • #13
                          My boat went back to Tennessee for the surgery under warranty.

                          Comment

                          Working...
                          X