Announcement

Collapse
No announcement yet.

Ballast pump failing possibly? Losing ballast

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ballast pump failing possibly? Losing ballast

    I been experiencing the same issue each day I’ve gone out this last week. I have an 2018 xt21, and each time I fill the right rear bag, I have to check it periodically because after about 45 minutes or so, the bag is down by almost half. My bilge has not been running and the locker is dry. Can water back flow through these pumps? That’s my only thought at this point, and would imagine then its a sign that the pump is going to fail completely?
    Thoughts?
    Thanks
    J

  • #2
    Likely your pump impeller needs replaced. When those start to wear, the pump can
    Drains water from the ballast. You may notice a longer fill time when the impeller need replaced.

    Comment


    • #3
      Yep, I’ve noticed longer fill times too! Gotcha
      Are they easy to replace at home or on a trip in a pinch?

      Comment


      • #4
        Originally posted by freeheeler88 View Post
        Yep, I’ve noticed longer fill times too! Gotcha
        Are they easy to replace at home or on a trip in a pinch?
        If you decide to do it on the water, make sure you close the intake valve. Super simple job. Rear pumps should be on the transom above the motor. Front pump should be at the front of the motor stbd side. Undo the brass cover, pull old impeller, lube up new one and install, replace cover and your done.

        Comment


        • #5
          Originally posted by LostDriver669 View Post
          Front pump should be at the front of the motor stbd side. Undo the brass cover, pull old impeller, lube up new one and install, replace cover and your done.
          My 2018 XT21 has the front ballast pump in the midship bilge hatch next to the drivers seat.....

          Sent from my SM-G965W using Tapatalk

          Comment

          Working...
          X