Announcement

Collapse
No announcement yet.

New T85 Pods Crackle + Popping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New T85 Pods Crackle + Popping

    Just took delivery of our X22, everything works perfectly apart from one of the T85 Pods, randomly it will crackle or pop multiple times before continuing to work. This occurs when the music is off and when it is on. Wondering if anyone has any advice for where to start or if they have suffered similar issues.

    Video was taken with the phone resting above the pods as we sometimes don't get them for 10-15 minutes or we get them in bursts as can be seen in the video. - cm-chat-media-video-1:fabbeddf-d24c-53e4-9fe0-7d63dd0e88d0:3339:0:0.MOV

    Cheers,

    - Sorry if some of you have seen this but I realised I had posted it in the wrong section.
    Attached Files

  • #2
    The popping sounds like an issue on the input side of the amp, or maybe with the amp itself. Have you tried re-securing the input cables? Otherwise since you just took delivery, it might be worth a trip back to the dealer.
    '18 XT22 w/5500 & Upgraded Premium Stereo
    (Previous- '08 X2 w/MCX)
    '16 F150 Platinum Screw 3.5L Eco 4x4

    I can help with Klipsch Stereo modifications
    www.chesnuttech.com

    Comment


    • #3
      Originally posted by eecyclone View Post
      The popping sounds like an issue on the input side of the amp, or maybe with the amp itself. Have you tried re-securing the input cables? Otherwise since you just took delivery, it might be worth a trip back to the dealer.
      Thanks for the reply, I am back at the boat tomorrow so I shall have a look, no experience with anything like this so I'll give it my best go. Spoke to the dealer and they came down the following day to take a look and it worked flawlessly the whole day, of course.

      Still get it every now and again so I shall try what you have said,

      Thanks

      Comment


      • #4
        Had a look, and everything seemed fine and worked perfectly for 3 hours then on our way back to the marina, it was like the devil possessed the sound system, showed the dealer and he's ordering a new Amp sometime this week, hopefully, it fixes it and it doesn't take too long to arrive!


        cm-chat-media-video-1:416fc825-278e-52e0-9e38-e43a32a914a7:11243:0:0.MOV
        Attached Files
        Last edited by MarcusP1; 07-16-2022, 03:42 PM.

        Comment


        • #5
          To anyone that may encounter this issue, replacement of the amp seems to have resolved it, for the most part, I noticed a few more pops but they stopped and it was fine from then on!

          Comment


          • #6
            Suggest amp cables and DSP box just to be sure and not worry about it. If it’s under warranty they will take
            care of it.

            Comment

            Working...
            X