Announcement

Collapse
No announcement yet.

2006 X2 Bow Ballast Bag Draining

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keep on Tryin'
    replied
    The one I had is like this

    https://marinesan.com/1-npt-y-valve-...astic%20Handle

    Leave a comment:


  • Hawgdriver
    replied
    Excellent!
    Would you happen to have a part number or pic of said in-line valve??
    Thank you!
    Originally posted by Keep on Tryin' View Post
    I had an old in-line valve laying around that I put in the supply line right before the KGB. I filled everything up then shut the valve. The bow sac / kgb did not leak, so I determined it had to be in the supply hose.

    Leave a comment:


  • WolverineFW
    replied
    Originally posted by Hawgdriver View Post
    This season…

    But wouldn’t the water drain out the intake rather than into the hull?
    You said you couldn't see any water or leaks in your original post. I didn't see anything saying you were getting water in the hull.

    Yes a bad impeller would drain out the intake under the boat.

    Sent from my SM-G965W using Tapatalk

    Leave a comment:


  • Keep on Tryin'
    replied
    I had an old in-line valve laying around that I put in the supply line right before the KGB. I filled everything up then shut the valve. The bow sac / kgb did not leak, so I determined it had to be in the supply hose.

    Leave a comment:


  • Hawgdriver
    replied
    How did you diagnose?
    Or did you just happen to replace that section of hose and noticed it was cracked?

    Originally posted by Keep on Tryin' View Post
    I was having a similar issue on my 2006 X30. I thought my KGB tank was cracked.
    It turned out there was slow leak as the result of a crack in the original fill line to the KGB (old and dry-rotted).
    Replaced the hose, and no more issues.

    Leave a comment:


  • Keep on Tryin'
    replied
    I was having a similar issue on my 2006 X30. I thought my KGB tank was cracked.
    It turned out there was slow leak as the result of a crack in the original fill line to the KGB (old and dry-rotted).
    Replaced the hose, and no more issues.

    Leave a comment:


  • Hawgdriver
    replied
    This season…
    But wouldn’t the water drain out the intake rather than into the hull?

    Originally posted by WolverineFW View Post
    When is the last time you changed the pump impeller? If it is too worn water will leak back out when the pump is off.

    Sent from my SM-G965W using Tapatalk

    Leave a comment:


  • WolverineFW
    replied
    When is the last time you changed the pump impeller? If it is too worn water will leak back out when the pump is off.

    Sent from my SM-G965W using Tapatalk

    Leave a comment:


  • Hawgdriver
    started a topic 2006 X2 Bow Ballast Bag Draining

    2006 X2 Bow Ballast Bag Draining

    I have a X2 with a plug and play bow ballast bag that’s draining without me emptying it. I can’t see anywhere that it’s leaking.
    My initial indication of the bag draining was my aft bilge running and emptying water from the hull while we were surfing.
    I’m sure I’m missing something but what is it?
    None of the fittings are loose.
    There is no wet carpet clues.
    My only guess is a cracked KGB (factory center tank that feeds into the bow bag).
    I do not know how to confirm this possibility.

    Can anyone offer some more ideas on ways to find the cause?
    Last edited by Hawgdriver; 07-24-2021, 01:14 AM.
Working...
X