Announcement

Collapse
No announcement yet.

obd diagnostics

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • obd diagnostics

    hi, does anyone know if a car type code reader for the engine electronics will work on a mastercraft x2 year2004 with a 350mcx engine?

  • #2
    I'm pretty sure the answer is no
    Lots of power is good, more is better, too much is just right.

    '91 prostar 190

    Comment


    • #3
      This has come up before and IIRC that requires a Marine-specific code reader. Rinda has them - don't know what it costs.

      http://www.rinda.com/marine/marine.htm


      '04 MariStar 230VRS/MCX

      Comment


      • #4
        600 for RINDA

        you can read codes with a test light and paper clip

        Comment


        • #5
          how do you read the codes with a test light +paper clip? sounds interesting..

          Comment


          • #6
            Originally posted by JUST-IN-TIME View Post
            600 for RINDA

            you can read codes with a test light and paper clip
            Read this post from Engine Nut first. He works for Indmar.

            http://www.mastercraft.com/teamtalk/...3&postcount=14
            '04 MariStar 230VRS/MCX

            Comment


            • #7
              you can do

              i have done it

              matters what year

              Comment


              • #8
                So I have a 2004 x-star with the mcx 350 and have a check engine light on . how would I retrive the codes with no scan tool?
                PM Me if you would like
                Thanks

                Comment


                • #9
                  I have been workin on an 04 x-star, the diagnostic scanner shows no codes, the engine seems to run fine, but the engine light/alarm is on and the boat seems to be in limp mode. I was told by a local mechanic that a transmission sensor could be causing the boat to limp. The oil in the tranny was pretty milky...I have flushed it 3 times attempting to remove the moisture. Any ideas or thoughts on the water in tranny causing light/ alrm/ limp mode? thx,

                  Comment


                  • #10
                    Originally posted by LDNCLR View Post
                    I have been workin on an 04 x-star, the diagnostic scanner shows no codes, the engine seems to run fine, but the engine light/alarm is on and the boat seems to be in limp mode. I was told by a local mechanic that a transmission sensor could be causing the boat to limp. The oil in the tranny was pretty milky...I have flushed it 3 times attempting to remove the moisture. Any ideas or thoughts on the water in tranny causing light/ alrm/ limp mode? thx,
                    I was under the impression that if it was the transmission, in addition to the "check engine" light, would flash "TRAN" on the MFD. I thought that was a temp alarm.

                    Milky fluid in the transmission usually means water in the transmission, and the usual source of such water is a failed transmission cooler. If there is no ATF in the bilge (which might indicate a bad seal) then I'd replace the transmission cooler (SkiDIM)
                    '04 MariStar 230VRS/MCX

                    Comment

                    Working...
                    X