Announcement

Collapse
No announcement yet.

MPH only gauge that works..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MPH only gauge that works..

    Ok so first post on here, we recently bought a new to us 1995 Mastercraft ProStar 190 and its our second mastercraft after selling our 96 ps190 several years ago. The boat is nice and has new upholstery and a solid engine but only the two MPH gauges and the Volt meter gauge work at all. The fuel, oil pressure, and rpm gauge basically do nothing, and the blower and bilge do not work at all either. We are basically looking to replace all of the gauges, blower, and bilge pump and I was wondering where the best place to order all of the parts is?? Have never bought parts for it... Once I replace everything I'll check out all of the wiring and see why nothing is working. Thank you!!

  • #2
    Welcome to Team Talk. That seems like an awful lot of electrical items to all be bad unless this is a flood recovery boat. Are you sure all items are defective, and tat there isn't an electrical issue involved?
    CUSTOM WHEEL & TIRE PACKAGES
    sigpic

    CUSTOM DECALS - EMAIL FOR MORE INFO

    $125 LED TRAILER LIGHT PACKAGE - FREE SHIPPING
    REBUILDING HOLLEY MARINE CARBS - $350 DELIVERED
    REBUILT COMPLETE MARINE HOLLEY 4160 CARBS $549 DELIVERED
    Email - [email protected]

    Comment


    • #3
      Have you checked voltages at all terminations... voltmeter etc? - Have you traced wires back to make sure their not just corroded or fuses blown?

      Many place to order. www.skidim.com good place to start. Blower out too? I would pull the switch panel and spend time with the voltmeter...
      sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

      Comment


      • #4
        Originally posted by 95 PS190 View Post
        Ok so first post on here, we recently bought a new to us 1995 Mastercraft ProStar 190 and its our second mastercraft after selling our 96 ps190 several years ago. The boat is nice and has new upholstery and a solid engine but only the two MPH gauges and the Volt meter gauge work at all. The fuel, oil pressure, and rpm gauge basically do nothing, and the blower and bilge do not work at all either. We are basically looking to replace all of the gauges, blower, and bilge pump and I was wondering where the best place to order all of the parts is?? Have never bought parts for it... Once I replace everything I'll check out all of the wiring and see why nothing is working. Thank you!!
        Welcome, your logic seems backwards to me, if it's me I would check out the wiring first before condeming all gauges, blower motors etc. are bad, which would be a huge a coincidence.
        /spĂ´rk/
        a spoon-shaped eating utensil with short tines at the tip

        Comment


        • #5
          No, I have no had the chance to look into it yet and it could be something simple but I know that we want to place the gauges regardless. It's also had an aftermarket stereo installed and the dash has definitely been taken apart before so it could really be anything. Im not even sure where to start. I think its weird that that not even the bilge or blower work. We also want to get a new throttle handle because the little "Click lock" mechanism doesnt work and you can just throw it from forward to reverse by pushing it

          Comment


          • #6
            I never said all the gauges were bad, sorry about the confusion. Im sure they work and have bad connections, but they are still super old and weathered and worth replacing while I'm going to have it all apart

            Comment


            • #7
              Theres no doubt in my mind that it's is almost all electrical and not the physical gauges themselves

              Comment


              • #8
                The click lock can be easily fix with a replacement spring from the hardware store for about .10. Took me longer to drive to Ace Hardware than to fix.
                Attached Files
                sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

                Comment


                • #9
                  Check any fuses on the dash or any that may have been added in the wiring by the PO.

                  Pick one item that is not working (blower) and try to troubleshoot that item only...you may find one issue and that may the cause of everything else.

                  Blowers are around $40 or so, Bilge Pumps are expensive if you get a bigger than stock one like I installed...think it was around $70.

                  Guages are a hit or miss on prices...check ebay...saw some go for $100 for all vs. other adds that were at the $450 mark.


                  Pull the old stereo out and start from scratch...that's is what we did on the 190 we bought last fall...no clue what the guy was trying to do except add hours to the tach.

                  Comment


                  • #10
                    Have you pulled the switch panel on the lower right hand side of helm? You may need a bank of switches as well. Do Navigation Lights and Horn work? We know 2 switches are probably dead - bilge and blower...
                    sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

                    Comment


                    • #11
                      Let me test some stuff out on it and get back to you guys.. I appreciate the quick replies though!! And the rocker switch for the bilge does light up but it doesnt do anything..

                      Comment


                      • #12
                        Post pictures - we're much better when we can see what's going on... this way you can spend less time fixing and more time skiing, boarding, footing, surfing, partying...did I say skiing?
                        sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

                        Comment


                        • #13
                          On the blower, does the switch light up? If so, check the actual fan inside the blower housing itself. Try to give it a spin with your finger (switch off). When I got my boat last fall, I spent a good bit of time tracing/testing the circuit, only to find that the fan itself had seized from not being used. Once I "broke" the fan free, it worked fine for a while (but ultimately i did replace as the bearing became noisy). Got a replacement for about $30 (mine was a 3" diameter). Good luck and welcome to the forum--great folks here always willing to lend a hand and sometimes a little humor or sarcasm. Oh yeah. . .pix are kind of a big deal here too!
                          "This one goes to eleven." 2007 ProStar 197 TT w/MCX and Powerslot.

                          Comment


                          • #14
                            Originally posted by Kweisner View Post
                            On the blower, does the switch light up? If so, check the actual fan inside the blower housing itself. Try to give it a spin with your finger (switch off). When I got my boat last fall, I spent a good bit of time tracing/testing the circuit, only to find that the fan itself had seized from not being used. Once I "broke" the fan free, it worked fine for a while (but ultimately i did replace as the bearing became noisy). Got a replacement for about $30 (mine was a 3" diameter). Good luck and welcome to the forum--great folks here always willing to lend a hand and sometimes a little humor or sarcasm. Oh yeah. . .pix are kind of a big deal here too!
                            When a bilge pump gets hung up, its usually due to corrosion and time to replace so it works when you need it. Sometimes they will suck in some debris and plug up. Put a garden hose against the pump outlet and give it a little backflush. Sometimes that is all it takes.
                            CUSTOM WHEEL & TIRE PACKAGES
                            sigpic

                            CUSTOM DECALS - EMAIL FOR MORE INFO

                            $125 LED TRAILER LIGHT PACKAGE - FREE SHIPPING
                            REBUILDING HOLLEY MARINE CARBS - $350 DELIVERED
                            REBUILT COMPLETE MARINE HOLLEY 4160 CARBS $549 DELIVERED
                            Email - [email protected]

                            Comment


                            • #15
                              I'm heading to work now but I should have time to work on t and take some pics for you guys on Sunday. The whole engine compartment definitely has some nasty buildup and the bilge does look pretty gross.. It's getting definitely getting replaced but I will try to see if it's just plugged up also

                              Comment

                              Working...
                              X