Announcement

Collapse
No announcement yet.

2012 X35 keeps dying with no warning, help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2012 X35 keeps dying with no warning, help!

    Everything will be working fine and we will be cruising down the lake or surfing and it will suddenly die as if the kill switch was engaged withe screen going off. This has been happening over and over this season only. Fortunately, after I put the throttle back to neutral, the key is still on and the screen reboots and I’m able to start the engine with no problems.

    Dealer has been trying to help, but coming up empty still.

  • #2
    You have it down at Table Rock Boats?
    Screws fall out all the time, the world is an imperfect place.

    Comment


    • #3
      Yep [emoji1303]

      Comment


      • #4
        12’s can be challenging. I was researching 12’s a few years back... Updates to software, kill switch, chaffed or loose wires to the ignition switch, electric panel/ breaker box connections or replacement to correct electrical gremlins.
        Screws fall out all the time, the world is an imperfect place.

        Comment


        • #5
          Thanks! Yeah I’ve ironed out a lot of rough spots. But this was new. May think about hardwiring the kill switch...

          Comment


          • #6
            Do you lose power to the gauges or do they stay active?

            edit: nvm misread the initial post. I got nothin other than it sounds like its not loose wiring since it starts up after you put it in neutral.
            Sam
            Website: www.SteadyPass.com
            Email: [email protected]
            Boat: 2005 Maristar 280 SST Twin Crusader 375

            Comment


            • #7
              Yes, Everything loses power

              Comment


              • #8
                After researching more and talking to my Father-in-law who has worked on his own boats for 50 years, I am going to try replacing the ignition switch first.

                If that doesn’t work, some threads here mentioned 50amp breaker on top of the engine or in the bilge that may close and then open when the boat resets.

                Got an ignition switch coming from MCpartsdepot hopefully next week.

                Comment


                • #9
                  There were some threads with 2011 and a 2012 X25 that mentioned ignition switch issues, run contact going bad.

                  Comment


                  • #10
                    Mine did the same, and took a couple trips to the dealer to figure out. Ended up being the 50 amp breaker on the engine. Zero problems since.

                    Sent from my SM-G900V using Tapatalk

                    Comment


                    • #11
                      Sweet! Thanks for replying! I just found your old post today actually! Only on TeamTalk!

                      Comment


                      • #12
                        Let me know if you need a pic of it, I can uncover the boat and get it for ya this weekend.
                        Originally posted by [email protected] View Post
                        Sweet! Thanks for replying! I just found your old post today actually! Only on TeamTalk!
                        Sent from my SM-G900V using Tapatalk

                        Comment


                        • #13
                          That would be super helpful if you get a chance!

                          Comment


                          • #14

                            Comment


                            • #15
                              Also, where can I get a new 50 amp breaker?

                              Comment

                              Working...
                              X