Announcement

Collapse
No announcement yet.

Pulling My Hair Out Over TBI Fuel Delivery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pulling My Hair Out Over TBI Fuel Delivery

    1999 \ 5.7 \ 310 \ TBI
    Winter got the best of me after doing everything I thought possible to winterize my boat.
    This was the first winter I've ever stored my baby outside and we had the worst winter in decades.
    About a month ago I pulled all four covers off and started to de-winterize it. I fired her up and run the engine for good 10 minutes to warm things up before changing the oil.

    When I uncapped the drain line all I had was clear water running out and then something followed that can only be described as a pudding like substance. I just wanted to die thinking how in the world could I have made such a lame mistake. After composing myself, it was time to pull engine. I spent a couple of weeks researching different avenues of engine replacement and stumbled onto a 6.2 stroker complete with Bowtie intake. The rebuilder was using a lot of terms like “Forged” / “Billit” / Lunati / “Full Roller”, ect….. but his story of someone leaving a deposit and not picking up the engine combined with the price kind of scared me but, got busy selling stuff so I could pay for the new engine. Due to being a little apprehensive & paying upfront just didn’t sit well so, ended driving an 1100 mile round trip so I could eyeball everything before handing over the $3500. After pulling the valve covers and oil pan I was surprised to see everything in order. Back to the house to started uncrating. Install went easy enough so, I thought I would be on the water by Memorial day but this No Fuel thing is kicking my Butt..

    I have checked everything I can think of but, without a working knowledge of this ECM and TBI system I’m just lost. I have purged and primed the fuel system, I have fuel pressure to the TBI unit and the injector leads are pulsing between 4.25 & 5 .4 volts when cranking. It fires right up if I supply the fuel via spray bottle.
    Attached Files

  • #2
    does the ECM have a signal from the dizzy?
    1981 MasterCraft
    19' Skier 351W PowerSlot
    Long gone is the Trans AM waiting for another

    Comment


    • #3
      is fuel spraying out of injectors? when you say fire up - does it stay running? - Is it getting signal from ECT?
      sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

      Comment


      • #4
        There is no spray from the injectors.. I have checked for voltage at the injector connectors and get a reading of 4 to 5 volts while cranking but will have to get a light on it as soon as I get home... The voltage does jump around so I assume thats the signal from the distributor.. It does fire up if I supply the fuel via a spray bottle so I know there is spark and the timing is close..

        Comment


        • #5
          TBI? pull the relays, swap the relays and check the fuses. check the pins in the ecm or the plug(take it you unplugged all when swapping block), make sure none are bent.

          So you are getting spark, fuel pressure to TBI unit but no spray of fuel from injector unts. take one of the injector units to parts store or GM dealer to check or try to buy one.
          1993 25th Anniversary Limited ProStar 190, #17

          Comment


          • #6
            I checked the fuses but have not swaped relays. I did not disconnect anything from the ECM as I just unbolted and set aside as a unit.

            Comment


            • #7
              I was told by my parts guy that there should be 12 volts at the injectors when the key is in the on position. I'm pretty sure I checked and the Fluk read something like .004

              Comment


              • #8
                +1 on bret's recommendation.

                is there and ECT sender on the motor? bad signal from ECT sensor can cause no start - push throttle forward (pull trans button on controller) - see if the allows injectors to toss some fuel.
                sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

                Comment


                • #9
                  My buddies 94 didnt start one year and swapped relays and it did - got a spare from skidim. the injectors fire from a driver in the ecm, not sure of the voltage.

                  google searchUnplug the injector's electrical connector and check the unit's coil resistance with an ohmmeter. Set the meter to a low resistance range and touch each electrical terminal on the injector with the ohmmeter's leads. If you read infinite resistance--no resistance at all--the injector's coil is opened. If you read zero resistance, the coil might be shorted to ground. In either case, the injector should be replaced. If you read resistance across the coil, go to the next step.

                  7
                  Connect a noid light at the injector harness connector--see the Tip section for more information. Start the engine and watch the noid light. If the noid light flashes, the injector is receiving power, and there might be a failed component inside the injector. If the noid light does not flash, the wiring harness or control module is not supplying voltage to the injector. Take your car to an auto shop for further troubleshooting.

                  Read more: http://www.ehow.com/how_4798806_chec...#ixzz33DWoANwB
                  1993 25th Anniversary Limited ProStar 190, #17

                  Comment


                  • #10
                    Ohm resistance should be 1.2-1.4 on TBI plugs
                    1993 25th Anniversary Limited ProStar 190, #17

                    Comment


                    • #11
                      Make sure you have spark while cranking. No spark, no fuel delivery.

                      Comment


                      • #12
                        http://www.fiveomotorsport.com/fuel-injectors/gmc/

                        TBI units at bottom
                        1993 25th Anniversary Limited ProStar 190, #17

                        Comment


                        • #13
                          pretty good post here from jimN helping someone 350 94 TBI

                          http://www.marineengine.com/boat-for...mar-TBI-Engine
                          1993 25th Anniversary Limited ProStar 190, #17

                          Comment


                          • #14
                            Wow, Thanks everyone.. I have to get my *** back to work but, this gives me some very good info to try as soon as I can get to the house here in about 3 hrs... I will post the results as soon as I get some..

                            Thanks again..

                            Comment


                            • #15
                              Any luck?
                              1993 25th Anniversary Limited ProStar 190, #17

                              Comment

                              Working...
                              X