Announcement

Collapse
No announcement yet.

Boat ran hot today

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Boat ran hot today

    took boat out today after leaving sand bar it ran hot. motor stalled and sputtered a little so I shut down. then seen steam coming from back of boat at water . sure enough when I turned the key back on temp gauge was pegged at 240. swam under to see if anything was stuck to thru hull ( no ) started engine up again it purred but temp didn't go down, so shut it rightback off. belt was still on. so Im guessing its the impeller. didn't change it before running it. first time its been on the water in two years. our river has been yuck. I have two questions:

    What is the impeller I need from skidim? its been a while since I bought one. I have one here in the package, but it doesn't match their numbers. the one I have here. is pleasurecraft RP061018.

    Second question:

    Could the short time of running hot have damaged my hoses or muffler.

    Its a 1999 X-star with the LTR 330 hp engine.


    Thanks for any info.

    and yes I know I should have changed the impeller before taking it on the first run. ( im an idiot )
    "Let me not pray to be sheltered from dangers, but to be fearless when facing them."

    1999 X-star, 330 LTR, Zero FLex tower.

  • #2
    Could just be clogged at the strainer. It happened to me on the river after we had some bad storm. Cleaned the strainer out and no more problems. Impeller was fine and no lasting issues.

    Comment


    • #3
      hoses and muffler should be ok... when is the last time you changed impeller? the impeller vanes take a set and then don't move as much water - impeller should be changed frequently.
      sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

      Comment


      • #4
        Originally posted by rem_pss308 View Post
        What is the impeller I need from skidim? its been a while since I bought one. I have one here in the package, but it doesn't match their numbers. the one I have here. is pleasurecraft RP061018.
        I believe that's the correct impeller: http://www.skidim.com/prodinfo.asp?number=RP061018

        Comment


        • #5
          Its has been 2 years since the last impeller change. I usually change it at the beginning of the season. but I didn't last year cause the river was messed up and we didn't use the boat. this year I just took it out for a warm up before changing oil. that was two weeks ago. decided to go out this weekend at last minute and didn't change impeller. Figured it would be ok. so roughly 2 years with one summer of use after change.

          Pulled the impeller. fins are ok. But it has slipped from the metal tube in the center.

          Now the question is:

          did it slip before or after it ran hot.

          I plan on changing out the thermostat then rigging a bucket so I can run it in the yard.


          nickespi: I don't have a strainer. but I have cleaned stuff out of the transmission cooler that was causing it to run a little hot before. Will check that when new thermostat is in, and I have a way to run boat.

          I need a airconditioned garage to work on this thing. Humid as hell outside.

          thanks for the input guys.

          Has anyone ever has a impeller slip the shaft?

          Mike
          "Let me not pray to be sheltered from dangers, but to be fearless when facing them."

          1999 X-star, 330 LTR, Zero FLex tower.

          Comment


          • #6
            Originally posted by rem_pss308 View Post

            Has anyone ever has a impeller slip the shaft?

            Mike
            Yep,3 weeks ago.It was 225 hrs old.
            Keep skiing!!!

            Comment


            • #7
              Back-flush your trans cooler, change you impeller, check and/or replace you T-stat. You may have sucked up some sand if you beached the boat on the sandbar.
              I was njskier on here.

              Comment


              • #8
                I call it a sandbar but its a place on the river with no trees or bushes, the bank slopes down. with the bow touching the bank at 90 degrees, I can stand at the swim deck and be tittie deep in the water. but yes plan on flushing it all. thanks
                "Let me not pray to be sheltered from dangers, but to be fearless when facing them."

                1999 X-star, 330 LTR, Zero FLex tower.

                Comment


                • #9
                  Changed the impeller. tested it, and it does fine. I guess two years of just sitting made it bad. or it was bad to start with. I will make sure I change it before any boating before season. thanks for all the responses. Mike
                  "Let me not pray to be sheltered from dangers, but to be fearless when facing them."

                  1999 X-star, 330 LTR, Zero FLex tower.

                  Comment

                  Working...
                  X