Announcement

Collapse
No announcement yet.

2004 MCX - Engine Cranks But Will Not Run

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2004 MCX - Engine Cranks But Will Not Run

    I'm looking for a little help with my Engine Cranks But Will Not Run issue. To the punch line, Diagnostic Trouble Code = "(81) Pump Low/Open". Intermittently starts and runs (as opposed to intermittently fails).

    Background: 2004 197 TT w/5.7 MCX engine. 900 hrs. Pulling a trick skier, hesitated and killed. Time to switch skiers anyway, boat started and ran for next skier - but killed just as I was idling after she dropped. Engine would crank, but not start. Towed back to the dock for the day.

    Since that point a week ago, I've tried starting the boat a number of times and it will start about 20% of my sessions. (Where a session is walking to the boat and trying to start. Usually numerous attempts to start. But generally, if it doesn't start on the first try, it'll never start in that session.)

    Most recently, I have hooked up the Rinda Diacom software and cable. Code "(81) Pump Low/Open" is the recorded trouble code. When it cranks but does not start, I have no spark from the coil to the distributor. At first I thought this was on the ignition side, but now believe (???) it is controlled by the ECM and due to a sensor reading.

    Before getting to that point (in reverse order, some of the order since I had spare parts before I borrowed Diacom and had fuel pressure gauge):
    - Measured the fuel pressure at the Schrader valve near the fuel rail. On Key On, would read at 55 psi, drop to 52 psi and drift down from there. Thinking that slightly low, swapped fuel pumps. Now with Key On, reads at 57 psi eases down to 55 psi and holds that for at least a couple minutes.
    - It did fire up for me this morning and I took it for a drive. Ran well. Upon return, fuel pressure remained at 57 psi for a couple minutes after stopping. In the first few tries, the engine fired right back up. I let it sit for ~5 minutes as I was cleaning out my tools. Now it cranks but won't fire. (When running, the fuel pressure jumps quickly between 55 and 60 psi.)
    - Inspected many electrical connections and put a dab of dielectic grease, especially those for the fuel pump, ignition control module and relays. I haven't done anything with those under the dash.
    - Swapped out the ignition control module. Put thermal grease on bottom.
    - Swapped out a spare relay for each of the three relays and tested one at a time.
    - Swapped out the coil.
    - Checked each of the 15A fuses. Swapped them around.
    - Filled the tank up completely with gas. It was at about 40%.
    - Swapped fuel pump.
    - Swapped out the distributor cap and rotor.
    - Confirmed the kill switch circuit was not the problem. (I bypassed it a number of years ago. But did disconnect and try, and in that case the gauges don't go to their readings.)

    Given the intermittent nature, I suspect a damaged wire or faulty electrical connection. But cannot find it. I have read through the fuel pump thread and others with Crank no Start, but cannot find the issue. Similarly, been through the Indmar shop manual chasing the DTC 81 = Pump Open/Low code.

    Help. Suggestions?

  • #2
    It sort of sounds like an intermittent electrical problem with your fuel pump. Some people have had trouble with the connector on top of the fuel pump module. Have you measured the fuel pressure on those times when you couldn't get it to start? Can you hear the fuel pump prime when it won't start?
    We defy the mafia!

    Comment


    • #3
      In your sessions, when it starts does it actually run well or is it lumpy?


      Sent from my iPhone using Tapatalk

      Comment


      • #4
        @blackhawk: I've observed no difference in those sessions between when it starts and when it won't. Often I've been doing this myself and the fuel pump is pretty quiet so take this next point with a grain of salt: When I turn the key to On, consistently pressures the rail. What I don't know is that it always re-pressures the rail in the first second when I try to start. According to the Indmar service manual, if the fuel pump doesn't run for the first second this points to an ignition problem. (i.e. the computer is controlling not to power the fuel pump)

        @osmonet: When it does start, it runs well. No hesitation. No lumpiness.

        Comment


        • #5
          I am having a similar issue with my LT1, not a lot of troubleshoot time yesterday as we had guests on the boat. I think it's electrical for me because I keep forgetting to switch back to all when we're done swimming. So when I crank the radio cuts out and the engine idles rough and dies. I switched the batteries off for a couple of minutes and then put both batteries on and it ran fine. I plan to go out Friday for the day with just the family, I will play with it more then and let you know.

          Sent from my SAMSUNG-SM-N920A using Tapatalk
          -Cory 2.0ld

          98 Maristar 225VRS - "Frankenstar"
          91 PS190 -Sold

          RIP No1

          Comment


          • #6
            While my old man is a TV repairman and has a beechin' set of tools that I can use, I did call a buddy over who has more knowledge on the electrical side of this. We went thru the Indmar suggested steps step-by-step. Unfortunately, step #18 on the Distributor Ignition System Check is not 'Go grab a cold beverage'. Instead, it says 'Replace faulty pick-up coil'. I checked the pick-up coil using another method (ohm resistance) and indicates the same. This will require pulling out the distributor...which has the potential to lead to "How do you time these engine?"

            Of to the parts store to get the ignition pick-up coil. I'll let you know if this $15 part is the culprit.

            Bongo

            Comment


            • #7
              To close this thread out, confirming it was my pick-up coil that went bad. Pulled the distributor, swapped out the pick-up coil, reinstalled distributor and the boat fired right up. When through a few stop / start cycles, etc. and all appears to be good.

              Whew. Now back to skiing.

              Comment


              • #8
                wow... could catch... that's a very low failure rate part...
                sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

                Comment


                • #9
                  Glad that you got it figured out. What was the part # of the pick up coil for future reference? Any pics?
                  We defy the mafia!

                  Comment


                  • #10
                    Bump....can you point us to the part number and post pics? I just lost a week at Lake Powell and my story sounds just like yours!

                    Comment


                    • #11
                      Apparently I had the very same problem....same issues, tried to replace the same initial parts, and nothing.

                      I thought pick up coil initially and tested it - but at the time it didn't seem to present as an issue. I finally retested it while slightly wiggling the wires...the readings were all over the place indicating a failed part.

                      After I pulled the part I found very large amount of corrosion where the wire contacts the coil, and the conductor case was completely chafed through where the wire exits the pick up casing.

                      To test:
                      Connect an ohmmeter to the pigtail leads of the distributor, resistance reading should be 150-900 ohms. Reading should remain steady if wires are moved around. A second test is to connect one lead from the ohmmeter to ground and the other to either of the pigtail leads. If the meter shows a reading the pick-up coil is bad.

                      I also found this web site to be very helpful in diagnosing:
                      http://easyautodiagnostics.com/gm/4....-of-articles-1
                      http://easyautodiagnostics.com/gm/4....ed-icm-tests-1
                      http://easyautodiagnostics.com/gm/4....test-the-icm-1

                      Last but not least YouTube is amazing, it taught me how to do the repair myself. I purchased the part from Advanced Auto, BWD brand, same part as an '88 Camaro 5.7L.

                      Comment


                      • #12
                        Did not read the entire thread, but please check the Harness side (female) of where the Fuel Pump Relay connects to the Engine Harness, if your relay is very warm or you see melted plastic, you have resistance and the relay will be intermittent ... as more relays during troubleshooting are unplugged and plugged in ... it tends to push the female spade ends in the receiving connector down and away from the solid contact needed ... please check that ....
                        Ski in snow, ski in water, and always have fun!

                        2008 Prostar 214 MCX
                        1995 Prostar 190 "Evil Minion"
                        Previous 93 Prostar 190 1.5:1 GT40

                        "Left Foot Forward and preferring girls."
                        "Do you have Flake on that boat?"

                        Comment

                        Working...
                        X