Announcement

Collapse
No announcement yet.

Maristar 230 5.7L LTR puzzle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maristar 230 5.7L LTR puzzle

    Long story but I retrieved my boat from a bad service experience at a local repair shop and replaced a blown head gasket myself. I am almost done re-assembling everything and I have one empty plug in my block above the oil filter.

    See this pic:

    https://www.amazon.com/photos/share/...ltrtqPd3o0n5sA
    What does your boat have in this location? A plug, sensor?

    Thanks

    Pointman (East Tennessee)

  • #2
    Do you also have an unplug wire?
    Is your oil pressure sender install?
    Keep skiing!!!

    Comment


    • #3
      Tried to look at the photo, but nothing loads.
      Not sure I'll be much help, as I have a different motor, but I'd like to see anyway.
      G

      Comment


      • #4
        no. wiring harness is plugged up to everything it' supposed to be...
        [IMG][/IMG]

        try this link: http://imgur.com/PFnVYgV

        Comment


        • #5
          thanks for helping. I appreciate it.

          Comment


          • #6
            oil pressure sender is installed on top of the intake manifold next to where the distributor would be. (mine has the caddy coil pack ignition)

            Comment


            • #7
              this empty opening is slightly smaller than the drain ports in the block and wont accept the regular brass drain plugs. I'm at a loss as to what to do with it.

              Comment


              • #8
                here's a pic of another motor (LT1 I think)with an oil pressure sender in one port and nothing in the port that I have open on my motor.

                Comment


                • #9
                  Nothing goes in those holes. At least that's the way mine is.

                  OOPS just looked at your picture. Might just be a plug. I will take a look tomorrow and get a better look at mine and let you know.
                  Attached Files
                  99 MariStar 230 Sport LTR 330

                  Comment


                  • #10
                    mtajpa your pic helps solve the puzzle. You do not have anything (far right above your filter) in the location I am worried about. Thank for the assist!

                    Comment


                    • #11
                      I can confirm the threaded hole is not used on the LTR 330 engine. Im in the middle of replacing the head gaskets and manifolds unfortunately.
                      Attached Files

                      Comment


                      • #12
                        thanks.

                        great pic. it helps immensely, thanks! I just put head gaskets on too. if you need part # or any help ping me!

                        Comment

                        Working...
                        X