Announcement

Collapse
No announcement yet.

Bad (not good) Vibration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad (not good) Vibration

    Need help/advice
    I have a 99 Prostar 205 DD with LTR, I have a vibration that is worst during hole shot but does smooth out at higher rpms. I have ruled out fuel psi, prop, trans fluid level. Plugs don't look fouled, they have about 150 hours on them. What would your next stop be to try to fix vibration, you feel most of the vibration in the dash and side of boat. I did notice more water (steady small stream while moving) coming in the shaft drip than normal while I had it out yesterday afternoon. The boat is just about to turn over 500 hours.
    Will the drip seal cause vibration?
    Could a sensor be throwing anything off?
    Would you change plugs and wires?
    Any other suggestions?
    Thanks guys, y'all are a wealth of knowledge, 12 years of Mastercraft ownership and 12 years of gaining your knowledge on this forum.
    Thanks
    Mitchell
    Mitchell

  • #2
    Possibly your prop got dinged? Check that first. If that looks good it could be the shaft alignment. That could possibly explain more water coming in through the shaft seal. Seems odd that it happened all of the sudden.
    1992 Prostar 190

    Comment


    • #3
      I swapped to a newly reworked from oj prop, and I haven't had any strikes while on the water from either prop, prior or this one. I did have fuel pressure issues at the start of the summer and replaced pump, which brought my psi back up to the 40psi range. Plugs were showing a little "wet" after running. Will replace those next. How would you suggest I check alignment?
      Thanks again
      Mitchell
      Mitchell

      Comment


      • #4
        This thread helps explain the alignment process. If this doesn't answer your question, if you search "shaft alignment" the topic has been discussed many times on the forum and I'm sure you could find what you need.

        https://www.mastercraft.com/teamtalk...haft+alignment
        1992 Prostar 190

        Comment


        • #5
          Check all the small things above, but sounds to me like flex plat is on its way out. They vibrate bad under load but once load off then they are not torquing up so makes it smoother.

          Comment


          • #6
            I bought new plugs today and swapped them out when I went home for lunch, all plugs were dry and looked good but one was wet from fuel, so I may have had a fouled plug. I will give it a try this afternoon and see if that was it, if not i guess alignment/cutless bearings/shaft will be my next look, thanks again
            Mitchell
            Mitchell

            Comment

            Working...
            X