Announcement

Collapse
No announcement yet.

'02 Prostar 197 w/ Indmar 350 Predator

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • '02 Prostar 197 w/ Indmar 350 Predator

    New long block with about 10 hrs. Engine is running very lean based on bright white plugs. Fuel pressure, oil pressure, water temp, timing are all good. Boat starts, idels, runs like a champ. Plugs/wires are new. Fuel pump is new. Injectors appear to be fine. Local MC dealer said everything looks good and didn't seem too concerned about it, but it makes me nervous knowing that its running that lean. Any recommendations on what could be the culprit?
    2002 Prostar 197, Monteray Blue, Perfect Pass, Zero Flex Tower w/ Speakers & Lights, Bimini, Amp/Sub, Transom remote

  • #2
    The Predator is throttle body injected, correct? How sure are you that the fuel pressure is okay at high rpm and under load? I think the TBI engines from that model year should have 30psi fuel pressure. The injectors will deliver less fuel than the ECM is expecting if the fuel pressure is below spec.

    Comment


    • #3
      Originally posted by 32offer View Post
      Engine is running very lean based on bright white plugs.
      is this the only thing youre using to determine that its running lean? or does it exhibit any bucking or surging as well?

      Comment


      • #4
        Yes, its TBI, and i am getting 30psi at startup, idle, and revving it in driveway. I haven't tested it on the water under load. It runs great. I can be running at 25-30 mph and punch it and it doesnt hesitate or cough at all, so all seems good.
        2002 Prostar 197, Monteray Blue, Perfect Pass, Zero Flex Tower w/ Speakers & Lights, Bimini, Amp/Sub, Transom remote

        Comment

        Working...
        X