Announcement

Collapse
No announcement yet.

What Work did you do on your Mastercraft Today?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Waxed and buffed, cleaned seats, scrubbed carpet and drivers foot-well, and refinished the teak platform. The wood of my platform looked so good this year it gave me wood. Finally ready for the water.

    On deck is to replace the bunks and carpet with gatorbaks and rebuild some of the bunk supports. I'll get some quality assistance for that welding project.
    2003 ProStar 197, MCX and Powerslot.

    "When injustice becomes law, resistance becomes duty" - Thomas Jefferson
    "Freedom is beneficial to everyone equally" - Ron Paul
    15%'er

    Comment


    • Click image for larger version

Name:	IMG_4684.jpg
Views:	1
Size:	93.1 KB
ID:	2410946
      Click image for larger version

Name:	IMG_4825.jpg
Views:	1
Size:	128.9 KB
ID:	2410947
      Fixed the awful bird’s nest of house wiring I found causing a short to the blower. Found a stray wire that went to the bilge pump float switch, wired it up, but it still doesn’t work on auto, just manual. Those auto switches go out by themselves often—or do I need to check wiring again? Seems like it’s only a few years old.

      Comment


      • Originally posted by MarCraft1991 View Post
        [ATTACH]204210[/ATTACH]
        [ATTACH]204211[/ATTACH]
        Fixed the awful bird’s nest of house wiring I found causing a short to the blower. Found a stray wire that went to the bilge pump float switch, wired it up, but it still doesn’t work on auto, just manual. Those auto switches go out by themselves often—or do I need to check wiring again? Seems like it’s only a few years old.
        Check wiring. Find a good schematic and re-check. I am not at my primary machine or I'd post it up. You are on the right track.

        .
        93 190
        (safe click)
        John 14:6
        (safe click)

        Comment


        • Put a new throttle body on it today.
          Attached Files
          1989 Prostar 190 351 sold
          2008 Prostar 197 LY6

          Comment


          • Looks good. Fun to get new, shiny parts!

            Comment


            • That model pump does not have a float switch on it.. i dont see the float switch in the pictures

              Sent from my SM-G955U using Tapatalk
              sigpic...A bad day water skiing still beats a good day at work...1995 Pro Star 205....

              Comment


              • With my son taking the boat 3 hours away this weekend, I did not want any issues (X14 on a single axle). Checked the hubs out and this side looked a little milky, the oil seal was seeping on the backside of the hub. The cap came off real easy, the little plug...I'll need a new one.
                Attached Files
                https://badges.fuelly.com/images/smallsig-us/302328.png
                1988 prostar 190 SOLD
                2001 Prostar 209 SOLD

                Comment


                • Originally posted by zsqure View Post
                  With my son taking the boat 3 hours away this weekend, I did not want any issues (X14 on a single axle). Checked the hubs out and this side looked a little milky, the oil seal was seeping on the backside of the hub. The cap came off real easy, the little plug...I'll need a new one.
                  Good call..

                  .
                  93 190
                  (safe click)
                  John 14:6
                  (safe click)

                  Comment


                  • Made an angle ring for my stereo remote, now I can actually read what the screen says!




                    Sent from my iPhone using Tapatalk

                    Comment


                    • Originally posted by Gianfranco View Post
                      Made an angle ring for my stereo remote, now I can actually read what the screen says!
                      Looks good. There is an old thread here about a fellow from Australia making pods very similar to that. I actually bought one (US $120) thinking (then) about putting it on my 93 for a remote mount but no where to mount it, as I thought.

                      Looking for a small dash pod now for my OEM clock.

                      Another member here ordered and installed the one from Australia in this thread.

                      Good job on the fabrication.

                      I like it.

                      .
                      93 190
                      (safe click)
                      John 14:6
                      (safe click)

                      Comment


                      • Originally posted by Gianfranco View Post
                        Made an angle ring for my stereo remote, now I can actually read what the screen says!




                        Sent from my iPhone using Tapatalk
                        Nice work
                        1989 Prostar 190 351 sold
                        2008 Prostar 197 LY6

                        Comment


                        • that looks nice, what did you use for material ? What is the little knob to the left ?

                          Comment


                          • Installed new Bilge Blower, only because I have an aversion to loud noises and fireballs!
                            Attached Files
                            NEW BOAT:2004 197TT

                            PREVIOUS BOAT:1993 Prostar 205

                            Comment


                            • Originally posted by carlsonwa View Post
                              that looks nice, what did you use for material ? What is the little knob to the left ?

                              I bought a 3” black abs pipe and cut one end at 15 degree on my miter saw. The knob is JL amplifier remote level control that is hooked up to the amp powering my wakeboard tower speakers, so I can control the tower speakers volume on the fly.


                              Sent from my iPhone using Tapatalk

                              Comment


                              • What Work did you do on your Mastercraft Today?

                                Guy who owned it before me had gone a little crazy with NAILS on the platform. Always bugged me but didn’t have an excuse for an immediate fix until it finally split…after some heftier passengers sat on the edge.


                                Last edited by MarCraft1991; 07-25-2021, 05:53 AM.

                                Comment

                                Working...
                                X