Announcement

Collapse
No announcement yet.

Trouble maintaining good wave

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble maintaining good wave

    Has any one had issue with consistency of their surf wave? I have a 2016 X2. We will be surfing everything going good then suddenly (without changing anything using the gen2 pre set up) the wave just gets choppy. Seems to typically happen at the end of the day so normally head in can never find any issues go the next day works perfectly fine couple days later same thing out of no where wave is super washy.

  • #2
    Just to add to this the one thing I did notice when this starts to happen is the boat seems to have a tougher time maintaining the set speed

    Comment


    • #3
      Just to add to this the one thing I did notice when this starts to happen is the boat seems to have a tougher time maintaining the set speed

      Comment


      • #4
        You have an actuator going bad. Common, but easy fix.

        Comment


        • #5
          Actuator is my guess as well.

          Do you run auto-launch when you surf, or shut it off? I always leave mine off when surfing because it speeds the time to a clean wave when we start each time. If you're running it, it could add to the instances when you have the above issue (particularly if your software is updated to three tab launch). Not saying auto-launch is your issue, but with more tabs moving around, if one is occasionally acting up, you're going to see it more.

          Comment


          • #6
            Thank you I will replace the actuator. And I do use auto launch I will try it without and see if that’s the issue. We will ride in the morning everything will be good then all the sudden washy even with the same rider no adjustment they will fall after riding an awesome wave pick them up to go again and it’s terrible . So head in can’t find anything go a couple hours later and works fine.

            Comment


            • #7
              I have a friend with the Gen 1 system and auto launch. After having 2 actuators go bad in a single season we quit using it entirely. Gen 1 sucked to begin with and the profiles were unusable. After the second tab failed we ditched the Gen 1 system entirely and started using a shaper instead of the tabs and never looked back. We've taken quick "outlaw"runs with just the stock ballast and the driver in the boat and can surf just fine.

              If you get a chance some time you may want to borrow a shaper and see how your boat does without the "surf" system. It may surprise you.

              Comment

              Working...
              X