Announcement

Collapse
No announcement yet.

Winterization Process/What is this?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Winterization Process/What is this?

    I'll be winterizing my 2004 Mastercraft X10 boat myself this year and I have a quick question as to what exactly this valve and hose runs to. Looks like it runs to the front of the boat... Just want to make sure I'm not missing anything in the winterization process.

    Thanks in advance!
    Attached Files

  • #2
    Shut off valve for the heater.
    -Tim

    Making boomers great again!! Boomin'

    Comment


    • #3
      Yep, heater supply hose. Be sure you get the water blown out of the heater and push some antifreeze through it.

      Comment


      • #4
        Not factory, though, fwiw.
        Prior boats - (3) X14's, (3) Prostars, and a Tristar.

        Comment


        • #5
          Awesome thanks a ton!!

          Comment


          • #6
            The one on my 07 looked just like that and supposedly was order from the factory with the option. I always thought it looked out of place but I also worked on an 06 X2 that had the same valve.

            One other observation, don't know if you removed it but it looks like the hose clamp is missing from the hose on the valve. If so I'd make sure one gets installed on that line.

            Comment


            • #7
              Also check to see where the return line from the heater attaches to the system. You may need to remove that also. Mine is plumbed into the raw water intake at the bottom of the bilge. Sometimes they come back into the return side of the water pump.

              Also your Cylinder #4 injector looks cockeyed. Maybe it's OK that way?
              2005 X2, Viper Red, MCX, Acme 1285, PPass, rear 750 sacs, KBS, IBS, Bennett Wake Plate
              (previous) 2001 X5, 1991 TriStar 190

              Comment


              • #8
                That's from Home Depot

                Comment


                • #9
                  Originally posted by JohnE View Post
                  Not factory, though, fwiw.
                  Mine looked just like that - from the factory.

                  Comment


                  • #10
                    Originally posted by Skyskiguy View Post
                    Mine looked just like that - from the factory.
                    Same here and I've seen several of these.

                    Comment

                    Working...
                    X