Announcement

Collapse
No announcement yet.

Bolts in my tracking fins 1982 S&S

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • thatsmrmastercraft
    replied
    I would take them out. I can't imagine what they would be there for.

    Leave a comment:


  • Olaff
    replied
    Anyone else? The fins are original equipment from the factory; have "MasterCraft" cast in the base and everything. I don't see any evidence of there ever being a sacrificial zinc anode mounted to the fin, no scratches or un-even wear...
    I think I'm just gonna take the bolts out and see what happens. I may gain an MPH on the top end due to the decreased drag.

    Leave a comment:


  • thatsmrmastercraft
    replied
    Never seen that before.

    Leave a comment:


  • Olaff
    replied
    ...And they look to be standard hardware, not stainless or zinc.

    Leave a comment:


  • Olaff
    replied
    That's what I thought at first; sacrificial anodes...It came from north Louisiana. There are no signs of salt water usage, no corrosion or anything like that.

    Leave a comment:


  • MC25
    replied
    Salt boat by chance?

    Leave a comment:


  • Olaff
    started a topic Bolts in my tracking fins 1982 S&S

    Bolts in my tracking fins 1982 S&S

    A 1982 Stars and Stripes with the factory Powerslot transmission upgrade found me Labor Day Weekend last year. Since it was a 3rd owner boat with 496 hours on it and always garage kept I had to buy her. Well we have put 100 hours on teaching my 4 kids to do all the board sports (I tell them it won't pull a tube!) We have my 6-year old skiing, wakeboarding, and kneeboarding.
    Enough side-story. This past weekend while underneath her with the polishing pad I noticed that all 3 tracking skegs have a single bolt horizontally through the center from port side to starboard. Each bolt is a 1/4"-20 about an inch long with a big washer on each side and a lockwasher/nut holding it on. I went back and looked at the original manual which doesn't show bolts. Anyone seen this before? Is it common? Is it a handling modification?
    Attached Files
Working...
X