Go Back   TeamTalk > View Profile

JimN JimN is offline

MC Master Poster

Visitor Messages

Showing Visitor Messages 11 to 20 of 28
  1. tazdevil
    08-14-2010 10:11 AM
    tazdevil
    hi jim
    you seem very knowledgable with idmar engines i have a rpt1 2006 runs fine the only problem is that three injectors wont open i tested them on the bench they work fine but the computer won t open them i am running on a 30psi pump mercruiser coolfuel gen 11 any idea why 3 injectors won t open there are no mastercraft dealers near thanks
  2. boyd
    06-12-2010 05:20 PM
    boyd
    Jim,
    You have helped me before. Hopefully you can do it again. I bought a new to me 87 supra. PCM. Starter is turning over very slowly. New battery, cable connections, I cleaned all the connections. It is original starter. Boat only has 302 hours on it and it's VERY clean. The last owner had the small battery connections coming from the cables to the battery(trolling motor), they were also melted off and he replaced with replacment connections. So, it's been hot before (battery)
    Do you think new starter is next ?
    Is rebuilding the starter just as good. Is there anything else to check ?
    Thank you.
    BOYD
  3. J NORRIS
    02-18-2010 05:14 PM
    J NORRIS
    Jim,
    I am planning on hooking the hull on my 2001 prostar 209. I have contacted Houston Master Craft and the drawing I got from them is no help at all. It had no dimensions on it! It looked like they wrote it on a napkin while drinking at the bar. I have a reputable fiberglass company here in Houston call Northwest Fiberglass to do the work. However I need the dimensions for them to be able to do the work. If you can help me in anyway it is much appreciated.
    Jim Norris
    (713)725-5901 if you feel like talking in person about it.
    or just reply to J NORRIS on the board.
  4. fentong
    08-19-2009 10:23 PM
    fentong
    Jim, you seem to be one of the more knowlegable trouble shooters for electrical issues on this forum. I posted an issue yesterday titled Gauges Problems (yeah I know bad choice of title to get attention). I was hoping you could take a look and reply if you have any thoughts on what the issue might be. Any help would be greatly appreciated.
  5. EricB
    08-17-2009 02:19 PM
    EricB
    Jim;
    I have a waterpump seal leaking on my 98 w/LT1. From the looks of it, the engine circulation pump is camshaft driven?
    What's the best way to replace that seal. Can it be done by removing the front watrepump cover, or do i have to take off the whole pump and reseal that way?

    thanks,
    EricB
  6. JimN
    07-06-2009 11:11 PM
    JimN
    That's possible but I would still like you to try running a ground from the splice to the battery negative. As I posted, they had a bulletin for these and that was the fix at the time. If that doesn't fix it, then I would look at a new MDC box. Also, look at the terminals on the plug and if the box opens, look inside- if the speedos have pitot tubes instead of a paddlewheel, water can get inside if you have hard freezes in winter and the tubes aren't cleared out when winterizing.
  7. apexer
    07-06-2009 10:00 PM
    apexer
    Hi Jim,you seem to know about the boat,any ways MC told me it would most likly be the MDC box,what do you think,thanks
  8. smorlang
    07-02-2009 12:06 PM
    smorlang
    Hi Jim, I've sent you a couple of replys but get an error message so not sure if they are making it to you. The moderator has moved the thread to engines/drive trains under maintenance, thanks for any assistance.
  9. smorlang
    06-30-2009 09:55 PM
    smorlang
    Hi Jim, I'm a newbie but I have a post in the general discussion about a 1999 x-star with a hot start problem. Your responses to other posts have been very helpful and gotten me as far as the post indicates but I could use a little direction. Any assistance would be appreciated...thanks
  10. the legend
    05-16-2009 10:45 PM
    the legend
    How's life treating you. I thought you were going to visit me at my new shop? In case you forgot I'm wrenching at Summerset Marine in Delavan, yes ,Wisconsin. Hope all is well and greasy! Hope to hear from you soon. Will

About Me

  • About JimN
    Team MasterCraft Member
    NO

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 03:48 PM
  • Join Date: 07-20-2004
  • Referrals: 0

All times are GMT -4. The time now is 06:30 PM.


2018