Announcement

Collapse
No announcement yet.

Search Result

Collapse
14 results in 0.0384 seconds.
Keywords
Members
Tags
  •  

  • I ran an event at Lake Jordan in NC this past year. Greg Hodgins was awesome to work with. If there is not an event in your area, think of creating one. Greg and others will help you along the way.
    See more | Go to post

    Leave a comment:


  • pjm14945
    replied to Stereo and top gauges dead on 2007 X-2
    I found a good supplier for these boxes. They are manufactured for Mastercraft by Medallion. Here is a contact that will build to order within 2 weeks. Cost was $204 with shipping. I was seeing a variant model on eBay for $150 w/o shipping. I would have gone with eBay but I needed the specific...
    See more | Go to post

    Leave a comment:


  • pjm14945
    replied to Stereo and top gauges dead on 2007 X-2
    Update,

    I found that the problem is the MMDC. Since all the gauges were out, it had to be either a fuse or the MMDC. I checked the voltage and there was power on either side of the 3 AMP fuse for the MMDC. I'm calling my dealer tomorrow but I'm expecting to get a nice bill for one...
    See more | Go to post

    Leave a comment:


  • pjm14945
    started a topic Stereo and top gauges dead on 2007 X-2

    Stereo and top gauges dead on 2007 X-2

    Help! I have no power to the stereo and the top row of gauges including RPM, Speed, LCD display and Fuel. The engine can start, and the lower switches are working like blower and horn.

    I've checked the main breaker by the battery and that is good with voltage on both sides. All of...
    See more | Go to post

  • I installed similar Fly High sac system into my 2007 X2. The recommended way was to install the complete system that comes with valves and new vent lines. This means drilling 3 holes into your hull to have 3 vent lines for your soft sacs. The pumps then run to your valves, that direct the pump to...
    See more | Go to post

    Leave a comment:


  • pjm14945
    replied to Ballast Relay bad in 2007 X2
    Thanks for the info Jeff D. I didn't really want to replace the Jabsco pumps with Ballast Puppy. If I re-wired with the automotive relays, then I'd lose the run dry protection for the pumps. That's replacing one problem with another. I'll have to think about that one. I assume this would be similar...
    See more | Go to post

    Leave a comment:


  • pjm14945
    replied to Ballast Relay bad in 2007 X2
    The 20 min relay/timers in my 2007 X2 are marked with : Active Intelligence Version 1.1 Model: 18500 - 0520

    The pumps are Jabsco of course.

    I would love to have the run dry protection. That is great to save your impellers.

    I'll look into the links you...
    See more | Go to post

    Leave a comment:


  • pjm14945
    replied to Ballast Relay bad in 2007 X2
    The relay acts like a switch to supply power to the pump. Since there is only 2 wires to the pump, I assume that the voltage flips to put the pump into either fill or empty direction. The relay I'm having problems with can only fill and does not empty. I've tried the relay on 2 different pumps. ...
    See more | Go to post

    Leave a comment:


  • pjm14945
    started a topic Ballast Relay bad in 2007 X2

    Ballast Relay bad in 2007 X2

    I replaced the stock relays back in 2008 to get the 20 min timers. I have the Fly High sacs installed. The relays are great to fill but a pain trying to get both hard and soft tanks to empty. If the relays detect air, they will think you hit empty.

    Anyway, I now have a relay that has...
    See more | Go to post

  • Thank you for the reply.

    I've searched for ballast timers and haven't found the thread with tutorial on how to turn off timers. If anyone has that link, please pass it along. I wouldn't want to remove the turn off on empty (low amp draw) feature. That is great for protecting the impellers....
    See more | Go to post

    Leave a comment:


  • pjm14945
    started a topic '07 X-2 Ballast Relay Drain Blues

    '07 X-2 Ballast Relay Drain Blues

    I have an '07 X-2 on Lake Gaston in Virginia. I installed the Fly High 3 sac system. I programmed the relays to the max 6 min but they still were not able to fill both sacs on each pump.

    I worked with my dealer and they suggested I upgrade to the newer relays with a 10 (or 20 I forget)...
    See more | Go to post

  • Thanks, that did it. The light has not come on this weekend.
    See more | Go to post

    Leave a comment:


  • pjm14945
    started a topic How to reset check engine alarm on '07 X-2

    How to reset check engine alarm on '07 X-2

    I have an X-2 and I have the check engine light coming on. I had a fuel pump go bad. The fuse and relays were fine. The old pump was getting 12 volts to the fuel pum. I replaced the fuel pump and everything is working great. However, the check engine light and alarm continue to go off when the engine...
    See more | Go to post

  • Check Engine Light on 2007 X-2

    I have an X-2 and I'm having a similar problem. I had a fuel pump go bad on me. I replaced the fuel pump and everything is working great. However, the check engine light and alarm continue to go off when the engine starts up.

    Does anyone...
    See more | Go to post

    Leave a comment:

Working...
X