Announcement

Collapse
No announcement yet.

Search Result

Collapse
82 results in 0.0673 seconds.
Keywords
Members
Tags
  •  

  • Yes, its TBI, and i am getting 30psi at startup, idle, and revving it in driveway. I haven't tested it on the water under load. It runs great. I can be running at 25-30 mph and punch it and it doesnt hesitate or cough at all, so all seems good.
    See more | Go to post

    Leave a comment:


  • 32offer
    replied to Old Clarion Remote in 2000 Prostar
    There is a bracket on the backside of the remote u have to remove. The 2 screws on the front only attach the trim piece to the panel
    See more | Go to post

    Leave a comment:


  • '02 Prostar 197 w/ Indmar 350 Predator

    New long block with about 10 hrs. Engine is running very lean based on bright white plugs. Fuel pressure, oil pressure, water temp, timing are all good. Boat starts, idels, runs like a champ. Plugs/wires are new. Fuel pump is new. Injectors appear to be fine. Local MC dealer said everything looks...
    See more | Go to post

  • 32offer
    started a topic UFP 44092 hub/rotor replacement

    UFP 44092 hub/rotor replacement

    I have an '02 MC Prostar197 with a UFP #44092 hub/rotor assembly that I am needing to replace. I cannot find this hub anywhere. Any good sources on where I can find an oil-bath hub to replace this one? I've checked several trailer supply companies and haven't got very far.
    Here are some...
    See more | Go to post

  • I'm pretty sure I used radiator clamps, but I did that last July and it's always started fine for the last 5 months if use
    See more | Go to post

    Leave a comment:


  • 32offer
    started a topic New long block = hard to start

    New long block = hard to start

    Just put in a new GM 350ci Vortec/Indmar long block in a 2002 Prostar 197. Install went great. But right off the bat, it is very hard to start sometimes. I'd say about 50% of the time, it will fire up fine, but the other half of the time it'll crank and crank and crank. It does help to put it in...
    See more | Go to post

  • 32offer
    replied to Best reman 5.7 Indmar?
    I went with a Jasper reman. My local MC dealer uses Jasper. My neighbor, who is a mechanic, uses Jasper, and said their customer service is top notch, and if you ever have a warranty issue, they'll take care of it, no questions asked. I am spending about $700-800 more than what I would've at Michigan...
    See more | Go to post

    Leave a comment:


  • 32offer
    replied to Best reman 5.7 Indmar?
    So....a couple of the engine suppliers i'm looking at are asking some particulars in order to get the right motor.
    Flat lifters vs. roller lifters?
    Stamp steel rockers vs. stamp steel rockers with a roller tip?

    Is there anyway to determine these without tearing into the...
    See more | Go to post

    Leave a comment:


  • 32offer
    replied to Best reman 5.7 Indmar?
    Blew a head gasket as far as I can tell. Smoked pretty good out of the motor cover when I fired it up. Had a burnt smell to it. When I drained the oil, it changed colors several times. Took it back out for a spin with a mechanic, and he took the oil cap off and it had a lot of blow-by....smoke rolling...
    See more | Go to post

    Leave a comment:


  • 32offer
    started a topic Best reman 5.7 Indmar?

    Best reman 5.7 Indmar?

    Looks like I'm in for a new motor for an '02 Prostar197. 350, 5.7l indmar with 310 HP currently. any suggestions on a motor? ive heard of Jasper, Marine Engine Depot, S and J engines, Michigan Motors, Marine Engines inc, Gearhead Engines. anyone had any good/bad experiences with any of these? I'm...
    See more | Go to post
    Last edited by 32offer; 07-23-2020, 08:01 PM. Reason: spelling errors

  • thank you. I'll give this info to my mechanic to see if any if these could be the culprit
    See more | Go to post

    Leave a comment:


  • '02 Prostar197 high oil pressure/knocking

    I have a '02 Prostar 197 with a 350 Indmar. 1st time I had boat out earlier this summer it developed a knocked noise under power, plus high oil pressure at about 180 psi. It had fresh oil in it from last winterization. After less than 2 hrs of run time the oil was burnt. I put fresh oil/filter in...
    See more | Go to post

  • 32offer
    replied to XMD1 cutting out
    All audio shuts down, not just the tower speakers and sub. the head unit is just driving the 4 factory speakers. I have not measured any of the voltage, impedance... It happens both when the boat is running and not running. I have turned the bass way down, and it still does it. but I have not disconnected...
    See more | Go to post

    Leave a comment:


  • 32offer
    started a topic XMD1 cutting out

    XMD1 cutting out

    I have a Clarion xmd1 head unit hooked up with the factory clarion speakers, 2 tower speakers, and a 10" sub. The tower speaks and sub are run off of a 4-channel amp. When I bump the volume up to about 60%, the system shuts down until I decrease the volume. This is in a 2002 prostar 197. I...
    See more | Go to post

  • 32offer
    started a topic xdm1 ipod connection

    xdm1 ipod connection

    I currently have a disc changer hooked up on my '02 ps197's xdm1 head unit. I have driver and transom remotes which I don't want to have to change. Is there an adapter cable available to hookup an iPod and/or smartphone with slacker radio rather than the changer? Or some other option?
    See more | Go to post
Working...
X