Announcement

Collapse
No announcement yet.

Search Result

Collapse
119 results in 0.0438 seconds.
Keywords
Members
Tags
  •  

  • Mathewfamily
    replied to 2010 X30 low hours
    Back on the market, 2010 X30 w/380 hrs

    I’m putting it back out there, we used it 5 times this year. $42k.
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to 2010 X30 low hours
    Shoot me a text with any questions to 920-460-4258...
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to 2010 X30 low hours
    Check out my photo albums for pics
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    started a topic 2010 X30 low hours

    2010 X30 low hours

    Interior looks brand new and the boat has just over 300 hours. We are only selling due to moving South and buying a center console fishing boat, which means I would consider trade on a fishing boat with front seating. I will add more photos tonight of the interior. She has a trailer and full cover that...
    See more | Go to post

  • Mathewfamily
    started a topic I need Debbie's number

    I need Debbie's number

    I am in need of a drive shaft for my X30 and Debbie had one at one time. I need her number to contact her to see if she still has it.
    See more | Go to post

  • That one does not have the shock, you are thinking of Skyski. I have the Pro ST (Shock Tower), I do like the advice about the knee pads. That is a great suggestion that I need to invest in. I am attempting inverts right now and yep a helmet is a must, especially with ear covers.
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to Speedometer issues
    After many hours of searching and checking wires for breaks or grounding issues I found the problem thanks to another member having a similar issues and him responding to a message I sent him. I unplugged the zero off antenna to find water in the sealed plug! I left this unplugged and everything starting...
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to Speedometer not working
    I am having similar issues as far as wires and glitches dealing with the actuators and speedometers. The only difference being both my speedometers were reading 0.0. So, I read a forum stating that their speedometer was reading 0.0 and sent them a message asking how they fixed it, turns out that the...
    See more | Go to post

    Leave a comment:


  • I am in the middle of reupholstering my 2010 and I bought all my vinyl from GSL. I have the luxury of living 45 mins away from them so I went to their facility and hand picked out what I need. They had one of the MasterCraft vinyl I needed but the others are vinyl they had from other manufactures...
    See more | Go to post

    Leave a comment:


  • I just reset mine, again, and it is very picky on the speed. When you attempt to do it does it shut you down on the first push up or when you push it the second time on the down motion? I ask because it would shut me down right away if I hit down first so it is up down up down however if I hit up...
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to Speedometer issues
    Spent some quality time with the boat and tested the wires coming off the triducer to the ECM and found that the signal is getting to the ECU. I have ran into a road block because I can not find the pin location for the CAN message that is sent from the ECU to the Medallion Viper system to display....
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to Who is Running ACME Props
    I just purchased my first ACME, went with a 1285 on my X30 and man does it shoot out of the hole now. This prop is hands down better than the OJ I had on it. I am VERY pleased.
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to Speedometer issues
    I checked the wires from triducer to plug for Medallion Viper blue box and they are all good. So I am assuming that the issues that I am having is related to the blue box. I have an email to Medallion asking if they will test my box if I send it to them. I found a new one for $700, normally $1000....
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    replied to Speedometer issues
    Last night I checked the ground and power wires going to the triducer and all was good at 12v. I have pretty much narrowed it down to the Blue Viper box or some other module that I can't find. Does anyone know where the Speedo Module, if one exist, is located? My Temp is still at 32F, which is an...
    See more | Go to post

    Leave a comment:


  • Mathewfamily
    started a topic Speedometer issues

    Speedometer issues

    I bought a new triducer, not cheap, thinking it would be a plug and play fix but no luck. If I check all gauges thru the BIG system the manual gauge moves with the rest. My depth and water temp is registering. Depth seems accurate but temp seems off. It was saying the water was 32 degrees. No way that...
    See more | Go to post
Working...
X