Announcement

Collapse
No announcement yet.

Search Result

Collapse
19 results in 0.0060 seconds.
Keywords
Members
Tags
ignition x
  •  

  • Battery Reverse Polarity

    Sorry - wrong forum
    See more | Go to post
    Last edited by Island Jim; 05-04-2020, 08:21 PM. Reason: Wrong forum

  • MCX – Good Fuel Pressure, Good Spark, No Start

    Long story short…we get to our campsite at Lake Powell 30 miles from the marina, set up camp and then go out to do some boarding. Engine starts fine, we idle about 100 feet away from our anchor and the engine sputters and dies. We end up being blessed by some VERY GENEROUS pontoon boaters towing...
    See more | Go to post

  • Bwinsky
    started a topic 2005 xstar mcx ignition module failing

    2005 xstar mcx ignition module failing

    Hi folks,

    Been working through issues.

    Key switch failed, replaced.

    Fuel pump, low growl, replaced.

    No spark, replaced ICM, advanced auto parts. Started up a few times over a couple of days. Ran good.

    Now, no start, no spark....
    See more | Go to post

  • Bwinsky
    started a topic 2005 xstar mcx no spark, Again!

    2005 xstar mcx no spark, Again!

    Hi folks,

    Been working through issues.

    Key switch failed, replaced.

    Fuel pump, low growl, replaced.

    No spark, replaced ICM, advanced auto parts. Started up a few times over a couple of days. Ran good.

    Now, no start, no spark....
    See more | Go to post
    Last edited by Bwinsky; 08-15-2018, 12:41 PM. Reason: updating title

  • jwskier
    started a topic 99 Prostar 205 - no power, boat won't wake up

    99 Prostar 205 - no power, boat won't wake up

    I need some help. Just got the boat out of storage to get it ready for the new season. Needed a new starter (it was getting weak at the end of last season). After replacing the starter, the boat is dead. Nothing happens when I turn the key. The battery is fully charged and i'm getting power to...
    See more | Go to post

  • bcl
    started a topic 89 PS 190 w/351 cranking while running

    89 PS 190 w/351 cranking while running

    This happened for a minute or so last weekend. Was just putting around, people swimming, had to move the boat a little. Started it, put it in gear, moved it, sounded strange. Back in neutral, still strange. Turned key off, engine continued to crank. The starter was stuck on while the boat was running...
    See more | Go to post

  • Mastercraft X2 2005 MCX 350 Misfire when warm

    Hi - I'm hoping someone can shed some light on an engine issue I seem to be having with my 2005 Mastercraft X2 MCX 350 hp V8.

    When starting from cold the engine runs perfectly well. After approximately 20 minutes (when the engine is fully warmed up the engine starts to misfire but in...
    See more | Go to post

  • 2008 X-45 400HP indmar vortec power train relay fault

    2008 X-45 400 HP indmar vortec, engine is cranking but not firing. Voltage on dash remaing above 10.5v even when cranking and oil pressure rises.
    diagnostic software kicking out:
    SPN 66014 power train relay contact fault
    FMI 4 voltage below normal.
    I have just replaced...
    See more | Go to post

  • stenovme
    started a topic No power to starter - diagnostic help please

    No power to starter - diagnostic help please

    I currently live overseas where there are no diagnostic tools available for my Mastercraft, so everything is manually found... My 06 xstar with Crusader engine has been working just fine, however the other day when trying to start, there was nothing at the starter... dash lit up fine, tested the batteries...
    See more | Go to post

  • dave-therave
    started a topic 1989 prostar electric ignition

    1989 prostar electric ignition

    I have a 1989 prostar with ford 351 engine it currently had points as I had electric before and it failed, suspect a cheap manufacturer parts installed. I want to change it back to electric as quick fix points now starting to wear. Can you please advise the right parts to pick.

    I've...
    See more | Go to post

  • robb1121
    started a topic 2009 Xtar Ignition Fuse Blowing

    2009 Xtar Ignition Fuse Blowing

    I have a 2009 PWT Xstar. On the lake this weekend and turned of boat to switch riders. When I went to start the boat again it did not turn over. Batteries fully charged, no radio on. Tracked it back to a blown fuse on the front of the engine. Replaced the fuse and started fine. Used the boat for another...
    See more | Go to post

  • Dkattman
    started a topic LT1 unable to keep idle alive

    LT1 unable to keep idle alive

    Recently purchased a 95 prostar 190 with an LT1, don't think it has the power slot. replaced water pump, mufflers, stats, impeller, etc. Otherwise appears in great shape. First time on the water it seemed to run fine. Last weekend it started just fine, died at idle after a minute or so. Then I...
    See more | Go to post

  • Ninjaneer
    started a topic Ignition issues

    Ignition issues

    My 1986 prostar is having ignition issues. I've replaced starter solenoid, battery, cables, ignition switch. But still no luck. It will fire once or twice, but once the battery stays hooked up, the ignition circuit breaker keeps popping out. Any ideas?
    See more | Go to post

  • Sharobike
    started a topic 1995 maristar won't turn off?

    1995 maristar won't turn off?

    Hello everyone! I bought a maristar a few months ago since I've done a little work to it (repacked the shaft and rudder, new prop, bildge, and mufflers) after I did all the maintance I took it out on the water and the boat wouldn't shut off.... I had to pull the fuel Injector off to starve the engine...
    See more | Go to post

  • ELB
    started a topic X-30 won't restart after engine is warm..

    X-30 won't restart after engine is warm..

    Please help. 2006 x-30 MCX (excelent condition and low time) will not restart after being shut off once the engine warms up. It turns over and kinda wants to start but will not fire up. Occasionally if I pump the throttle it will start and once it's started it runs great until its shut off again. ...
    See more | Go to post
Working...
X