Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Underwater Running Gear

Reply
 
Thread Tools Display Modes
  #11  
Old 04-09-2021, 08:00 PM
mike koen's Avatar
mike koen mike koen is offline
MC Fanatic
 
Join Date: May 2015
Boat: mastercraft x-14 2008 mcx
Location: Ontario Canada
Posts: 776
I need to get this done . MCOCD.
__________________
If she don't shine , she ain't mine
Reply With Quote
  #12  
Old 04-21-2021, 04:45 PM
Krw1225 Krw1225 is offline
TT Enthusiast
 
Join Date: Sep 2017
Boat: 2008 X-14, 40th Anniversary Edition, MCX w/ Powerslot
Location: Southeast
Posts: 435
Quote:
Originally Posted by BrianS View Post
Well, got it done. Used a razor blade to scrape the majority off, then used a nylon wheel on the Dremel to remove the rest. Tried acetone but it just smeared it around.

Couple pics below. No play in the rudder now, hope this resolves the leak as well.






Sent from my iPhone using Tapatalk
Nice work! I couldn’t bring myself to try this myself, mainly due to fear of Gel coat damage, so I had dealer for it at end of season. I used the boat once or twice before it was winterized, but it seemed to fix our leak from the port. Hope it did yours as well!
Reply With Quote
  #13  
Old 09-17-2021, 04:47 AM
danwell danwell is offline
TT Regular
 
Join Date: Oct 2018
Boat: X25
Location: Southeast
Posts: 77
Glad I've found this thread as I'm having the same issue on my boat.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:48 PM.


2020