Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 05-21-2016, 03:34 AM
dguerard dguerard is offline
TT Newbie
 
Join Date: May 2016
Boat: Prostar 190 1999
Location: FRANCE
Posts: 9
replace raw water pump

Hi everyone, i m french and i apologize for my very bad english.
I have an Indmar Engine 5,7 EFI on a Prostar 190 of the year 1999, and i ordered a raw water pump Sherwood P105, mine to be changed.
There are several holes on the new pump with several diameters, but i tried every positions, it does fit only with two of the 3 holes on the body of the axe of the crankshaft of my engine.
I m surprised because according to my supplier, the new pump is supposed to be standard for my engine.
Anyway, i mounted this new pump with only the 2 bolts instead 3, and the engine runs properly.
Is it a matter to continue to run the engine like this ?
Thanks for your answers
David
Reply With Quote
  #2  
Old 05-21-2016, 06:30 AM
jgraham37128 jgraham37128 is offline
TT Regular
 
Join Date: Oct 2012
Boat: 2016 Mastercraft X23
Location: Center-Hill Lake
Posts: 3,078
Compare it to the old one. I'm guessing you received the wrong part.
Reply With Quote
Reply

Tags
impeller, pump, raw, sherwood, water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:07 PM.


2020