Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #11  
Old 05-23-2021, 05:16 PM
jewbacca jewbacca is offline
TT Enthusiast
 
Join Date: Mar 2021
Boat: 2008 Mastercraft X1 RTP-1
Location: UT
Posts: 101
I sent my timers out to tr6coug and everything works perfectly. Another satisfied customer.

I also cleaned up the battery switch connections. Quite a bit of corrosion on the posts. Went at them with a steel brush, but I may just replace it down the road.
Reply With Quote
  #12  
Old 05-23-2021, 05:23 PM
jewbacca jewbacca is offline
TT Enthusiast
 
Join Date: Mar 2021
Boat: 2008 Mastercraft X1 RTP-1
Location: UT
Posts: 101
Quote:
Originally Posted by Steel Horse View Post
My x1 is doing the exact same thing. Where are the timers and controller located if you donít mind to share?
On the X1 they're behind the control panel next to the driver's seat. I had to remove the seat to get access. Slide the seat back and forth to access the bolts. My panel has been altered, so reassembly wasn't a problem for me, but there are a few threads on here about reattachment.
Reply With Quote
  #13  
Old 05-26-2021, 01:38 AM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Devotee
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 1,009
Quote:
Originally Posted by jewbacca View Post
I sent my timers out to tr6coug and everything works perfectly. Another satisfied customer.
Happy to hear its all working well now
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:21 PM.


2020