Go Back   TeamTalk > General MasterCraft Topics > Tow Vehicles

Reply
 
Thread Tools Display Modes
  #1  
Old 07-22-2019, 09:47 AM
John Johnson John Johnson is offline
MC Fanatic
 
Join Date: Aug 2013
Boat: 2018 NXT22 Prior 2002 Maristar 230 VRS
Location: Southeast
Posts: 715
2014 6.7L PS Whine

My F250 whines when it comes up to temp. I've purged the fuel filters and pump (suggestion from PS forum), but it still happens. I assume if it was the turbo it would do it all the time. Anyone else have this issue? Water pump maybe?
Reply With Quote
  #2  
Old 07-22-2019, 10:00 AM
pmkkdx's Avatar
pmkkdx pmkkdx is offline
MC Maniac
 
Join Date: May 2009
Boat: Mastercraft, X2, 2004, Violet (purple) & white ... previous 1983 black/silver stars
Location: Southwest (Central Texas)
Posts: 2,546
possibly when up to temp, automatic fan kicks in causing the whine to pull more air thru the radiator. I had an older suburban that did that when towing during the summer heat.
Reply With Quote
  #3  
Old 07-22-2019, 10:05 AM
John Johnson John Johnson is offline
MC Fanatic
 
Join Date: Aug 2013
Boat: 2018 NXT22 Prior 2002 Maristar 230 VRS
Location: Southeast
Posts: 715
That would make sense. Maybe the fan bearings are wearing out.
Reply With Quote
  #4  
Old 09-18-2019, 11:42 PM
Proedge Proedge is offline
TT Regular
 
Join Date: Jun 2019
Boat: 2009 X-55
Location: Northwest
Posts: 85
My 6.7 had a whine like that and the dealer even replaced the power steering pump, because they were convinced it was the pump causing the whine. It turned out to be one of the idlers. Best way to diagnose a whine is to get a set of “mechanic’s ears’ and use place them onto the serpentine belt idlers. That was the only way I could pinpoint exactly where the whine was coming from.
Reply With Quote
  #5  
Old 11-11-2019, 04:35 AM
danwell danwell is offline
TT Regular
 
Join Date: Oct 2018
Boat: X25
Location: Southeast
Posts: 56
Any update on this? I'm having the same issue on my truck.
Reply With Quote
  #6  
Old 11-11-2019, 08:22 AM
John Johnson John Johnson is offline
MC Fanatic
 
Join Date: Aug 2013
Boat: 2018 NXT22 Prior 2002 Maristar 230 VRS
Location: Southeast
Posts: 715
Nope. Still does it. I got in a buddy's 2015 and his does it too.
Reply With Quote
  #7  
Old 11-11-2019, 07:59 PM
Proedge Proedge is offline
TT Regular
 
Join Date: Jun 2019
Boat: 2009 X-55
Location: Northwest
Posts: 85
did you check the idler pulleys? As i said, I can almost guarantee it's one of them making noise.
I've attached a picture of the idler and the mechanic's ears I'm referring to that you need to get in order to determine exactly where the noise is coming from.
Attached Images
  
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:11 PM.


2018