Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #141  
Old 09-04-2018, 07:15 PM
D2Dominator D2Dominator is offline
TT Regular
 
Join Date: May 2017
Boat: 2002 X-Star, Indmar
Location: Boston
Posts: 87
Quote:
Originally Posted by petemay121 View Post
Mine all fitted perfectly. Some that were a bit tight I just got a stanley knife and cut the black stuff as my "wood effect" stuff didn't exactly line up with the thicker black stuff, the black stuff cuts super easy. I lobe having all Faria gauges now that work all the time!


Thatís my fear... I donít want to cut the foam away as the trim panel is sandwiched in between the foam and the gauges.


Sent from my iPhone using Tapatalk
__________________
2002 X-Star Indmar 5.7 Vortec Predator

Reply With Quote
  #142  
Old 09-05-2018, 06:03 PM
petemay121 petemay121 is offline
TT Regular
 
Join Date: Aug 2017
Boat: Mastercraft, ProStar 190, 2001
Location: Canada
Posts: 46
Send a message via Skype™ to petemay121
It cuts so easy! Was a 2 min job to trim and slot the new gauges in.
__________________
2001 ProStar 190 330hp LTR
Reply With Quote
  #143  
Old 09-18-2018, 10:09 PM
ztarum ztarum is offline
TT Newbie
 
Join Date: Sep 2018
Boat: 2002 Prostar 197 6.0L
Location: Northeast
Posts: 17
So I just went through this with a 2002 Prostar 197 that I recently acquired. On my boat only the oil pressure gauge moved at all (but wasn't accurate), and the hour meter worked. Everything else was dead. The MMDC checked out voltage wise, and is likely fine (paddle wheel speedo, so common MDC failure point is eliminated), but I didn't want to buy a bunch of OEM gauges to test further so I went the Faria route.

In my case, a new coolant temperature sender was required (no analog signal to the MMDC to repurpose). I have the LQ9 engine, so I had trouble finding a temperature sensor that would work. Initially I tried a 3 wire sensor that lot or people use when they do LS engine swaps into older cars. This sensor has two wired for the engine computer (like my engine currently has), and one extra to signal an analog gauge. Unfortunately it turned out that the available sensor (fits a 1998 Camaro 5.7 by the way), does not match the scale of the Faria gauge.

This having failed, I decided to add an additional sender to the opposite head to supply the new gauge only. I purchased an adapter that was 1/8" NPT female to M12x1.5 male so I could use a standard sender in the LS head. This didn't work. The senders I could buy would not pass through the adapter without opening up the bore. If I had done that the brass adapter wall would have only been 0.030" thick and likely would have sheared off on install.

In the end I bought a larger Faria 3/8" NPT sender. Machined the threaded area down on my lathe and cut new M12x1.5 threads into the body. I was then able to directly mount the new sender into the head and this worked fine. If anyone wants to do similar, a machine shop should be able to do this for you fairly cheaply. Just bring the existing sender and the new ones so they can copy the design of the threads and sealing area. You will need to buy an appropriate copper crush washer as well. Note that the probe end of the sender is extremely thin metal. Do not attempt to grip it in the lathe chuck. Grip it by the hex end only or use a collet to avoid crushing the sender.

I also found that my fuel level sender was the wrong resistance scale as others have already reported. I ordered a new one from Centroid, but it hasn't arrived yet. I was impatient and order one from amazon in the 6" length.

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

It works fine. I cut the plug off the old Centroid sender and hooked two of the wired up to the new one (the third isn't used), so I preserve the original wiring harness. When the Centroid sender gets here I'll test it was well.

I think that cover most of the issues. A few other items to note. On this model the power to the MMDC is not switched with ignition, so I could not use that wire per the instructions. Instead I used the wire labeled SPDO from the harness. I also picked up the tach signal (gray wire) from the same point. Otherwise I did the same as the OP and repurposed most of the gauge harness, cutting off the old plugs and capping the unused yellow wires.

Oh, I went with the GPS speedos, and removed the older paddlewheel to install a Faria depth finder transducer. This is NOT recommended. The old housing for the Airmar speedo was extremely difficult to removed, and once out, the Faria transducer is a bit small for the hole. If I were to do it again, I would talk to Airmar and see if they had a transducer that would mount directly into the existing retractable speedo housing. That would have been so much easier. Unfortunately I had already broken the housing trying to remove it before I came to my senses, so there was no turning back.

That's it. I hope it's helpful for anyone trying to convert a 2002.

Thanks to the OP and other contributors for posting all the prior info. I couldn't have done it otherwise.

-Z

Last edited by ztarum; 09-18-2018 at 10:20 PM.
Reply With Quote
  #144  
Old 04-03-2019, 11:43 AM
MB230VRS MB230VRS is offline
TT Newbie
 
Join Date: Oct 2016
Boat: 2003 MariStar 230VRS
Location: Missouri
Posts: 5
Quote:
Originally Posted by G.Luke View Post
Thanks. I read through the whole thread again and I think Ive got it.

There appears to be a temp sender on the the bottom port side of my block with a single blue wire. Im going to just run that directly to the gauge. I will run the boat and see how that works.

I dont have pp. I'm hoping that the wiring is there for the tach. There are several unconnected (capped) wires under the dash that I assume are for options like pp that my boat didnt come with. I'll try to figure that out
How'd you do with finding a tach wire? I appear to have the same harness/MMDC you do without PP. What about the temp sensor?

Did you source a new fuel sending unit?
Reply With Quote
  #145  
Old 04-04-2019, 07:41 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,314
Tach wire should be a gray wire in the wires going to the Perfect Pass. You will probably need a new sending unit.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #146  
Old 04-04-2019, 05:26 PM
MB230VRS MB230VRS is offline
TT Newbie
 
Join Date: Oct 2016
Boat: 2003 MariStar 230VRS
Location: Missouri
Posts: 5
Quote:
Originally Posted by 76S&S View Post
Tach wire should be a gray wire in the wires going to the Perfect Pass. You will probably need a new sending unit.
I don't have perfect pass. Does it still go to the MMDC?
Reply With Quote
  #147  
Old 04-04-2019, 11:52 PM
handleandrew's Avatar
handleandrew handleandrew is offline
TT Enthusiast
 
Join Date: Mar 2013
Boat: 2003 X9 w/MCX
Location: NorFL, St. John's River
Posts: 117
Depending on year, the mmdc doesn't have a dedicated tach wire running to it. The info comes in on the ecm wire. Nonetheless, all mcs were prewired for pp, so even if you don't have pp the grey wire should be behind the drivers kick.
__________________
[email protected]@36mph. Hopin' to someday ski w/ the big boys... :-/
Reply With Quote
  #148  
Old 04-14-2019, 04:16 PM
Coach Mike's Avatar
Coach Mike Coach Mike is offline
TT Enthusiast
 
Join Date: Sep 2014
Boat: 2015 Mastercraft X-30 and 2000 Prostar 190
Location: Midwest
Posts: 284
Quote:
Originally Posted by 76S&S View Post
Well, I finally tackled this on my 02 Star. First, thanks to JeffD for his work in documenting the process and second, thanks to the additional contributors.

I'll see if I can add any value to this thread.
I went with Faria gauges that came with the GPS speedo. The GPS speedo requires a constant 12v and a switched 12v. Coming out of the MMDC 24 pin connector, there is a red and a red with black stripe. The red is switched and the the red with black stripe is where I picked up the constant 12v. I picked up the grey wire for the tach off of the PerfectPass. There was enough wire stuffed behind the kick panel that I was able to pull it through and tap in to the wire. I did have to install an new temp sending unit and run a dedicated wire, the analog gauges will not work with the two wire sending unit found on our motors.

Only thing left for me is a new fuel sending unit and then it will be complete.
I finally got into this as well this weekend. Thanks to everyone for the shared details along the way. I have a 2000 ProStar 190 and also got the Faria GPS Speedo that needs a constant 12V source as stated above. Anyone know which wire I'd use for that source from the MDC? I suppose I could run a wire to the battery, but if there is already a line from the harness, I'd prefer that.

I may be asking about the sender for fuel level later, but it is snowing here today, so I might be a while

Thanks,

Mike
Reply With Quote
  #149  
Old 04-20-2019, 10:09 AM
Coach Mike's Avatar
Coach Mike Coach Mike is offline
TT Enthusiast
 
Join Date: Sep 2014
Boat: 2015 Mastercraft X-30 and 2000 Prostar 190
Location: Midwest
Posts: 284
Contacted Joel and will need a new sending as stated by all here. Still need to call Mary though. Anyone know what the unit will cost from them these days and will this one work as an alternative source:

https://www.amazon.com/Moeller-Marin...8-4&th=1&psc=1

Also still womdering about the constant 12V wiring needed for the GPS speedometer.

Thanks!
Reply With Quote
  #150  
Old 04-20-2019, 11:18 AM
Tsumi Tsumi is offline
MC Fanatic
 
Join Date: Feb 2012
Boat: 2001 X-star 5.7L LTR, 2000 Prostar 190 5.7L LTR, both dark green
Location: Pacific
Posts: 836
Plenty of constant on 12v sources behind the dash. Tap into one of the accessory power lines. I think I recall on my harness there was a line that was unused that was constant on. I believe constant on lines are orange.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:55 PM.


2018