Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #11  
Old 07-17-2019, 10:39 AM
CrashCourse316 CrashCourse316 is offline
MC Fanatic
 
Join Date: Jun 2018
Boat: MasterCraft, 280 SST, 2005, Twin 375 Crusader
Location: Michigan
Posts: 640
Quote:
Originally Posted by Soder View Post
(yes, there's an Arduino MEGA at the bottom of that box)
if it works it ain't stupid. And yea i hear noises that mechanics wouldn't even flinch at and I think to myself...this is it... this is how it all ends...
__________________
Sam
Website: www.SteadyPass.com
Email: [email protected]
Boat: 2005 Maristar 280 SST Twin Crusader 375
Reply With Quote
  #12  
Old 07-17-2019, 11:12 AM
Soder's Avatar
Soder Soder is offline
TT Enthusiast
 
Join Date: Apr 2016
Boat: 2004 X-30 MCX
Location: Utah
Posts: 190
Here's the picture of the culprit right next to the transmission and driveshaft seal.
Attached Images
 
__________________
2004 X-30 5.7L MCX
Reply With Quote
  #13  
Old 07-17-2019, 12:21 PM
CrashCourse316 CrashCourse316 is offline
MC Fanatic
 
Join Date: Jun 2018
Boat: MasterCraft, 280 SST, 2005, Twin 375 Crusader
Location: Michigan
Posts: 640
Buy a new boat......current one will never be a same after hearing that noise once.
__________________
Sam
Website: www.SteadyPass.com
Email: [email protected]
Boat: 2005 Maristar 280 SST Twin Crusader 375
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:13 PM.


2018