Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-21-2021, 03:37 PM
Need a mc Need a mc is offline
TT Regular
 
Join Date: Jun 2014
Boat: 1997 205 Prostar 275hp.
Location: Midwest
Posts: 95
97 prostar 205

I put new cap, rotor, wires, plugs, fuel filter in last year.
new impeller this year
needed a fuel pump--was able to find a used one from a friend of a friend-so I didn't have to reconfigure a new since they don't make the exact one anymore.-that is working fine

Then last weekend the boat Motor wont go above 3600 rpm/ 38 mph.

thoughts
Reply With Quote
  #2  
Old 07-21-2021, 04:10 PM
JMann's Avatar
JMann JMann is offline
MC Fanatic
 
Join Date: Nov 2008
Boat: 1991 Prostar 190, Indmar 351
Location: West coat, San Francisco bay area
Posts: 832
I'd say check the fuel pressure. How good was that used fuel pump?
Reply With Quote
  #3  
Old 07-21-2021, 08:02 PM
Need a mc Need a mc is offline
TT Regular
 
Join Date: Jun 2014
Boat: 1997 205 Prostar 275hp.
Location: Midwest
Posts: 95
Drained the gas tank. New gas was put in plus a new fuel filter. Running well again.
Reply With Quote
  #4  
Old 07-21-2021, 09:34 PM
mikeg205 mikeg205 is offline
Super Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 18,390
Send a message via Skype™ to mikeg205
Awesome to read u got a solution

Sent from my SM-G955U using Tapatalk
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:29 AM.


2020