Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 08-03-2021, 06:53 PM
RobertTriv RobertTriv is offline
TT Newbie
 
Join Date: Feb 2021
Boat: 2010 X15 350 MCX
Location: Canada
Posts: 27
Is my hard tank ballast broken?

Hey guys, I was doing an oil change on the boat today and noticed that when I put pressure on the hard tank ballasts that the tanks would flex a lot. When looking closer the side of the tank has a big V in it. Both rear tanks look like this. They are both carpeted over so I cant tell overly easy if there is an issue or not. I do have piggy back bags that are 460lbs each that sit on the hard tanks. Is there just a cover over the tanks that bulge out with pressure put on them and the tanks under are fine? Is the V in the side of the tank normal? I dont have any leaks or other issues but to me this looks like its about be explode out the side any day now. Boat is a 2010 X15. Pictures attached of the concern.
Attached Images
 
Reply With Quote
  #2  
Old 08-08-2021, 04:18 PM
RobertTriv RobertTriv is offline
TT Newbie
 
Join Date: Feb 2021
Boat: 2010 X15 350 MCX
Location: Canada
Posts: 27
I peeled up a corner of the carpet and it looks like that is the tank directly. Does anybody elses tank look like this?
Reply With Quote
  #3  
Old 08-09-2021, 10:51 AM
jgraham37128 jgraham37128 is offline
TT Regular
 
Join Date: Oct 2012
Boat: 2016 Mastercraft X23
Location: Center-Hill Lake
Posts: 3,354
probably normal does it have a lot of water in the hull? That will tell if there's a problem.
Reply With Quote
  #4  
Old 08-09-2021, 10:52 AM
jgraham37128 jgraham37128 is offline
TT Regular
 
Join Date: Oct 2012
Boat: 2016 Mastercraft X23
Location: Center-Hill Lake
Posts: 3,354
I see you have a 2010. I had a 2010 x2 and it looked just like this.
Reply With Quote
  #5  
Old 08-09-2021, 05:53 PM
RobertTriv RobertTriv is offline
TT Newbie
 
Join Date: Feb 2021
Boat: 2010 X15 350 MCX
Location: Canada
Posts: 27
Quote:
Originally Posted by jgraham37128 View Post
probably normal does it have a lot of water in the hull? That will tell if there's a problem.
Quote:
Originally Posted by jgraham37128 View Post
I see you have a 2010. I had a 2010 x2 and it looked just like this.
Awesome thats good to hear. No its not leaking at all just wanted to confirm if they are about to burst or if its normal
Reply With Quote
  #6  
Old 08-22-2021, 08:30 AM
Lutfu Lutfu is offline
TT Regular
 
Join Date: May 2016
Boat: X2 2015
Location: South
Posts: 73
Both hard tanks on our 2014 X2 look the same.. my feeling is that the piggy back bags put too much weight on the hard tanks.. I am thinking about installing some sort of frame to support the hard tanks and even out the weight of the ballast bags.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:12 PM.


2020